File python-xmlschema.spec of Package python-xmlschema
#
# spec file for package python-xmlschema
#
# Copyright (c) 2021 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?!python_module:%define python_module() python-%{**} python3-%{**}}
Name: python-xmlschema
Version: 1.0.18
Release: 0
Summary: An XML Schema validator and decoder
License: MIT
URL: https://github.com/sissaschool/xmlschema
Source: https://files.pythonhosted.org/packages/source/x/xmlschema/xmlschema-%{version}.tar.gz
%if 0%{?suse_version} <= 120300
Source1: python-xmlschema-rpmlintrc
%endif
# https://github.com/sissaschool/xmlschema/commit/6e3ff636e24bc689f54cfb9a11fd025b10c56273
Patch0: 0001-Add-XML-resource-access-control.patch
# https://github.com/sissaschool/xmlschema/commit/e0aa7f92482a2732ff0e63239bfb5f8c941d8af7
Patch1: 0002-Raise-error-for-allow-sandbox-when-no-base_url-is-pr.patch
# https://github.com/sissaschool/xmlschema/commit/aa8c38863ab23c13f67e7a3b5a8f0714102271d1
Patch2: 0003-Fix-allow-sandbox-access-check-on-windows.patch
Patch3: 0004-Make-compatible-with-python2.patch
BuildRequires: %{python_module elementpath >= 1.3.0}
BuildRequires: %{python_module pytest}
BuildRequires: %{python_module setuptools}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
Requires: python-elementpath >= 1.3.0
BuildArch: noarch
%python_subpackages
%description
The *xmlschema* library is an implementation of `XML Schema <http://www.w3.org/2001/XMLSchema>`_
for Python.
%prep
%setup -q -n xmlschema-%{version}
%patch0 -p1
%patch1 -p1
%patch2 -p1
%patch3 -p1
# do not hardcode versions
sed -i -e 's:~=:>=:' setup.py
# do not bother with memory validation
rm xmlschema/tests/check_memory.py
rm xmlschema/tests/test_memory.py
%build
export LANG="en_US.UTF8"
%python_build
%install
export LANG="en_US.UTF8"
%python_install
%python_expand rm -r %{buildroot}%{$python_sitelib}/xmlschema/tests
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%check
export LANG="en_US.UTF8"
%pytest
%files %{python_files}
%doc CHANGELOG.rst README.rst
%license LICENSE
%{python_sitelib}/*
%changelog