File openchange.spec of Package openchange
#
# spec file for package openchange (Version 0.8.2)
#
# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
# Copyright (c) 2007 Suman Manjunath
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
# norootforbuild
%define _release_nick ROMULUS
%define sambaprefix /usr/%{_lib}/samba4
%define _prefix %{sambaprefix}
%define _exec_prefix %{sambaprefix}
%define _bindir %{sambaprefix}/bin
%define _sbindir %{sambaprefix}/sbin
%define _sysconfdir %{sambaprefix}/etc
%define _datadir %{sambaprefix}/share
%define _includedir %{sambaprefix}/include
%define _libdir %{sambaprefix}/%{_lib}
%define _libexecdir %{sambaprefix}/%{_lib}
%define _localstatedir %{sambaprefix}/var/%{_lib}
%define _sharedstatedir %{sambaprefix}/com
%define _mandir %{sambaprefix}/man
%define _infodir %{sambaprefix}/share/info
BuildRequires: bison
BuildRequires: boost-devel
BuildRequires: cyrus-sasl-devel
BuildRequires: doxygen
BuildRequires: file-devel
BuildRequires: flex
BuildRequires: gcc
BuildRequires: gcc-c++
BuildRequires: glibc-devel
BuildRequires: gnu-crypto
BuildRequires: gnutls-devel
BuildRequires: libaio-devel
BuildRequires: libgcrypt-devel
BuildRequires: pam-devel
BuildRequires: popt-devel
BuildRequires: pkg-config
Name: openchange
# The tarball corresponds to r949 from trunk
Version: 0.8.2
Release: 0.<RELEASE1>
Summary: Open Source Exchange Server Alternative Native Outlook Compatibility
Group: Productivity/Networking/Email/Servers
License: GPL v3 or later
Source0: %{name}-%{version}.tar.bz2
Patch0: libdir-fix.diff
Url: http://www.openchange.org/
BuildRoot: %{_tmppath}/%{name}-%{version}-build
AutoReqProv: on
#BuildRequires: libtalloc-samba4-devel libtdb-samba4-devel libtevent-samba4-devel samba4-devel
BuildRequires: libtalloc-devel libtdb-devel libtevent-devel samba4-devel
# Requires: libtalloc1 libtdb1 samba4
Requires: cyrus-sasl glibc gnu-crypto libaio libgcrypt11 libgnutls26 pam popt
#Requires: libtalloc1 libtdb1 libtevent0 samba
%description
OpenChange aims to provide a portable Open Source implementation of
Microsoft Exchange Server and Exchange protocols. Exchange is a
groupware server designed to work with Microsoft Outlook, and providing
features such as a messaging server, shared calendars, contact
databases, public folders, notes and tasks.
OpenChange provides the MAPI library which can be used by third party
messaging clients such as GNOME Evolution or Mozilla Thunderbird.
Authors:
--------
Julien Kerihuel <j.kerihuel@openchange.org>
%package devel
License: GPL v3 or later
Summary: Open Source Exchange Server Alternative Native Outlook Compatibility
Group: Productivity/Networking/Email/Servers
Requires: openchange = %{?epoch:}%{version}-%{release}
# Requires: libtalloc-samba4-devel libtdb-samba4-devel samba4-devel
%description devel
OpenChange aims to provide a portable Open Source implementation of
Microsoft Exchange Server and Exchange protocols. Exchange is a
groupware server designed to work with Microsoft Outlook, and providing
features such as a messaging server, shared calendars, contact
databases, public folders, notes and tasks.
OpenChange provides the MAPI library which can be used by third party
messaging clients such as GNOME Evolution or Mozilla Thunderbird.
Authors:
--------
Julien Kerihuel <j.kerihuel@openchange.org>
%prep
%setup -n %{name}-%{version}
%ifarch x86_64
%patch0 -p1
%endif
%build
export PKG_CONFIG_PATH=%{_libdir}/pkgconfig
./autogen.sh \
--with-samba=%{sambaprefix}
%{configure} \
--with-samba=%{sambaprefix}
%{__make}
%install
%{makeinstall}
# FIXME - these have to respect the --with-modulesdir, but they don't = FHS badness
%{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/openchange/modules
%{__mv} $RPM_BUILD_ROOT/%{_prefix}/modules/* $RPM_BUILD_ROOT/%{_libdir}/openchange/modules/
%{__rm} -rf $RPM_BUILD_ROOT/%{_prefix}/modules
%{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/openchange/setup
%{__mv} $RPM_BUILD_ROOT/%{_datadir}/setup/* $RPM_BUILD_ROOT/%{_libdir}/openchange/setup
%{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/setup
%post
/sbin/ldconfig
%postun
/sbin/ldconfig
%clean
%{__rm} -rf $RPM_BUILD_ROOT
%files
%defattr(-, root, root)
%{_bindir}/exchange2mbox
%{_bindir}/locale_codepage
%{_bindir}/mapiprofile
%{_bindir}/mapitest
%{_bindir}/openchangeclient
%{_bindir}/openchangemapidump
%{_bindir}/openchangepfadmin
%{_bindir}/schemaIDGUID
%{_libdir}/libmapi*.so.*
%{_libdir}/libocpf.so.*
%{_libdir}/mapistore_backends
%{_libdir}/nagios
#%{_prefix}/modules
%dir %{_libdir}/python*
%dir %{_libdir}/python*/site-packages
%{_libdir}/python*/site-packages/openchange
%{_libdir}/openchange
%files devel
%defattr(-,root,root)
# %{_includedir}/gen_ndr/exchange.h
# %{_includedir}/gen_ndr/property.h
%{_includedir}/gen_ndr
%{_includedir}/libmapi
%{_includedir}/libmapi++
%{_includedir}/libmapiadmin
%{_includedir}/libocpf
%{_includedir}/libmapi*.h
%{_includedir}/mapistore
%{_libdir}/pkgconfig/libmapi*.pc
%{_libdir}/pkgconfig/libocpf.pc
%{_libdir}/libmapi*.so
%{_libdir}/libocpf.so
%changelog