File howdy.spec of Package howdy
#
# spec file for package howdy
#
# Copyright (c) 2021 Dmitriy O. Afanasyev, <dmafanasyev@gmail.com>.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
Name: howdy
Version: 2.6.1
Release: 0
Summary: Windows Hello™ style authentication for Linux
License: MIT
Url: https://github.com/boltgolt/%{name}
Group: System/Base
Source: https://github.com/boltgolt/%{name}/archive/v%{version}.tar.gz
Patch0: howdy-cli-py-shebang.patch
Patch1: howdy-cli-py-getuid.patch
BuildRequires: wget
Requires: ffmpeg
%if 0%{?suse_version} > 1500
# With Tumbleweed use python-python-pam and pam-python otherwise
Requires: python-python-pam
%else
Requires: pam-python
%endif
%if 0%{?sle_version} == 150300 && 0%{?is_opensuse}
# With Leap 15.3 use python3-opencv and python3-opencv3 otherwise
Requires: python3-opencv
%else
Requires: python3-opencv3
%endif
Recommends: python3-dlib
%description
Windows Hello™ style authentication for Linux. Use your built-in IR emitters and camera in combination with face recognition to prove who you are.
%prep
%autosetup -p1
( cd src/dlib-data/ ; ln %{_sourcedir}/*.bz2 . ; bzip2 -d -f *.bz2 )
%build
# nothing to build
%install
rm -rf
mkdir -p %{buildroot}%{_libdir}/security/%{name}
rm -fr src/*~
cp -pr src/* %{buildroot}%{_libdir}/security/%{name}
# Delete some files from src/dlib-data
rm -fr %{buildroot}%{_libdir}/security/%{name}/dlib-data/{Readme.md,install.sh,.gitignore}
#Add bash completion
mkdir -p %{buildroot}%{_datadir}/bash-completion/completions
install -Dm 644 autocomplete/%{name} %{buildroot}%{_datadir}/bash-completion/completions
# Create an executable
mkdir -p %{buildroot}%{_bindir}
chmod +x %{buildroot}%{_libdir}/security/%{name}/cli.py
ln -s %{_libdir}/security/%{name}/cli.py %{buildroot}%{_bindir}/%{name}
%post
echo "See https://en.opensuse.org/SDB:Facial_authentication for configuration manual"
%files
%license LICENSE
%doc README.md
%{_bindir}/%{name}
%dir %{_libdir}/security
%{_libdir}/security/%{name}
%{_datadir}/bash-completion/completions/%{name}
%config(noreplace) %{_libdir}/security/%{name}/config.ini
%changelog