File erlang-ejson.spec of Package erlang-ejson

#
# spec file for package erlang-ejson
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

Name:           erlang-ejson
Version:        0.1.0+git.1337789959.2a78a82
%define mod_ver %(echo "%{version}" | cut -d "+" -f1)
Release:        0
License:        Apache-2.0
Summary:        Decode and encode JSON
Url:            http://github.com/kevsmith/ejson/
Group:          Development/Libraries/Other
Source:         ejson-%{version}.tar.gz
Patch01:        PATCH01-remove-dependency-from-rebar.config-file.patch
BuildRequires:  erlang-rebar
Requires:       erlang
BuildRequires:  erlang-mochiweb
Requires:       erlang-mochiweb
BuildRequires:  gcc-c++
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
decode and encode JSON into/from Erlang terms using Elang NIF library if 
available. This the module used in CouchDB project ported a standalone module 
with rebar support.

%prep
%setup -n ejson-%{version}
%patch01

%build
%rebar compile escriptize

%install
for dir in ebin priv ; do
  install -d %{buildroot}%{erlang_libdir}/ejson-%{mod_ver}/${dir}
  cp -r ${dir}/* %{buildroot}%{erlang_libdir}/ejson-%{mod_ver}/${dir}/
done

%files
%defattr(-,root,root)
%dir %{erlang_libdir}/ejson-%{mod_ver}
%{erlang_libdir}/ejson-%{mod_ver}/ebin
%{erlang_libdir}/ejson-%{mod_ver}/priv

openSUSE Build Service is sponsored by