File erlang-erlsom.spec of Package erlang-erlsom
#
# spec file for package erlang-erlsom
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: erlang-erlsom
Version: 0.0.0+git.1318156287.bc48604
%define mod_ver %(echo "%{version}" | cut -d "+" -f1)
Release: 0
License: GPL-3.0
Summary: XML parser for Erlang
Url: https://github.com/opscode/erlsom
Group: Development/Libraries/Other
Source: erlsom-%{version}.tar.gz
BuildRequires: erlang-rebar
Requires: erlang
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
XML parser for Erlang.
%prep
%setup -n erlsom-%{version}
%build
%rebar compile escriptize
%install
for dir in ebin include ; do
install -d %{buildroot}%{erlang_libdir}/erlsom-%{mod_ver}/${dir}
cp -r ${dir}/* %{buildroot}%{erlang_libdir}/erlsom-%{mod_ver}/${dir}/
done
%files
%defattr(-,root,root)
%dir %{erlang_libdir}/erlsom-%{mod_ver}
%{erlang_libdir}/erlsom-%{mod_ver}/ebin
%{erlang_libdir}/erlsom-%{mod_ver}/include