File erlang-ibrowse.spec of Package erlang-ibrowse
#
# spec file for package erlang-ibrowse
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: erlang-ibrowse
Version: 0.0.0+git.1350943239.8f3f6a3
%define mod_ver %(echo "%{version}" | cut -d "+" -f1)
Release: 0
License: LGPL-2.1+
Summary: Ibrowse is a HTTP client
Url: http://github.com/opscode/ibrowse/
Group: Development/Libraries/Other
Source: ibrowse-%{version}.tar.gz
BuildRequires: erlang-rebar
Requires: erlang
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
ibrowse is a HTTP client written in erlang.
%prep
%setup -n ibrowse-%{version}
%build
%rebar compile escriptize
%install
for dir in ebin include priv ; do
install -d %{buildroot}%{erlang_libdir}/ibrowse-%{mod_ver}/${dir}
cp -r ${dir}/* %{buildroot}%{erlang_libdir}/ibrowse-%{mod_ver}/${dir}/
done
%files
%defattr(-,root,root)
%dir %{erlang_libdir}/ibrowse-%{mod_ver}
%{erlang_libdir}/ibrowse-%{mod_ver}/ebin
%{erlang_libdir}/ibrowse-%{mod_ver}/include
%{erlang_libdir}/ibrowse-%{mod_ver}/priv