File erlang-luerl.spec of Package erlang-luerl
#
# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%define app_name luerl
Name: erlang-%{app_name}
Version: 0.3
Release: 0
%define app_ver %(echo "%{version}" | cut -d "+" -f1)
License: Apache-2.0
Summary: Lua in Erlang
Url: https://github.com/rvirding/luerl
Group: Development/Libraries/Other
Source: %{app_name}-%{version}.tar.xz
Requires: erlang
BuildRequires: erlang
BuildRequires: erlang-rebar
BuildRoot: %{_tmppath}/%{name}-%{version}-build
Provides: %{name}-devel = %{version}-%{release}
%description
An experimental implementation of Lua 5.2 written solely in pure Erlang.
Some things which are known not to be implemented or work properly:
* label and goto
* tail-call optimisation in return
* only limited standard libraries
* proper handling of __metatable
* ...
%prep
%setup -q -n %{app_name}-%{version}
%build
%rebar compile
%install
for dir in ebin ; do
mkdir -p %{buildroot}%{erlang_libdir}/%{app_name}-%{app_ver}/${dir}
cp -r ${dir}/* %{buildroot}%{erlang_libdir}/%{app_name}-%{app_ver}/${dir}/
done
%check
%rebar eunit
%files
%defattr(-,root,root)
%dir %{erlang_libdir}/%{app_name}-%{app_ver}
%dir %{erlang_libdir}/%{app_name}-%{app_ver}/ebin
%{erlang_libdir}/%{app_name}-%{app_ver}/ebin/%{app_name}.app
%{erlang_libdir}/%{app_name}-%{app_ver}/ebin/*.beam
%changelog