File erlang-pooler.spec of Package erlang-pooler

#
# spec file for package erlang-pooler
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

Name:           erlang-pooler
Version:        0.0.2+git.1364072672.17f5590
%define mod_ver %(echo "%{version}" | cut -d "+" -f1)
Release:        0
License:        Apache-2.0
Summary:        An OTP Process Pool Application 
Url:            http://github.com/seth/pooler
Group:          Development/Libraries/Other
Source:         pooler-%{version}.tar.gz
Patch01:        PATCH01-remove-version-check-with-git.patch
BuildRequires:  erlang-rebar
Requires:       erlang
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
An OTP Process Pool Application 

%prep
%setup -n pooler-%{version}
%patch01

%build
%rebar compile escriptize

%install
for dir in ebin ; do
  install -d %{buildroot}%{erlang_libdir}/pooler-%{mod_ver}/${dir}
  cp -r ${dir}/* %{buildroot}%{erlang_libdir}/pooler-%{mod_ver}/${dir}/
done

%files
%defattr(-,root,root)
%dir %{erlang_libdir}/pooler-%{mod_ver}
%{erlang_libdir}/pooler-%{mod_ver}/ebin

openSUSE Build Service is sponsored by