File erlang-webmachine.spec of Package erlang-webmachine
#
# spec file for package erlang-webmachine
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: erlang-webmachine
Version: 1.10.0+git.1364703509.d705a49
%define mod_ver %(echo "%{version}" | cut -d "+" -f1)
Release: 0
License: Apache-2.0
Summary: A REST-based system for building web applications
Url: https://github.com/basho/webmachine
Group: Development/Libraries/Other
Source: webmachine-%{version}.tar.gz
Patch0: webmachine-relaxed-mochiweb-dep.patch
Patch1: no-werror.patch
BuildRequires: erlang-rebar
BuildRequires: erlang-mochiweb
Requires: erlang
Requires: erlang-mochiweb
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
Webmachine is an application layer that adds HTTP semantic awareness on top of
the excellent bit-pushing and HTTP syntax-management provided by mochiweb, and
provides a simple and clean way to connect that to your application’s behavior.
%prep
%setup -n webmachine-%{version}
%patch0 -p1
%patch1 -p1
chmod -x priv/trace/wmtrace.js priv/trace/wmtrace.css
%build
%rebar compile
%install
for dir in ebin priv include scripts ; do
install -d %{buildroot}%{erlang_libdir}/webmachine-%{mod_ver}/${dir}
cp -r ${dir}/* %{buildroot}%{erlang_libdir}/webmachine-%{mod_ver}/${dir}/
done
%check
%rebar ct
%files
%defattr(-,root,root)
%doc README.org LICENSE
%dir %{erlang_libdir}/webmachine-%{mod_ver}
%{erlang_libdir}/webmachine-%{mod_ver}/ebin
%{erlang_libdir}/webmachine-%{mod_ver}/priv
%{erlang_libdir}/webmachine-%{mod_ver}/include
%{erlang_libdir}/webmachine-%{mod_ver}/scripts
%changelog