File qt_dotgraph.spec of Package qt_dotgraph
%global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
%global __provides_exclude_from ^/opt/ros/melodic/.*$
%global __requires_exclude_from ^/opt/ros/melodic/.*$
Name: ros-melodic-qt-dotgraph
Version: 0.4.2
Release: 1%{?dist}
Summary: ROS qt_dotgraph package
License: BSD
Group: Development/Libraries
URL: http://ros.org/wiki/qt_dotgraph
Source0: qt_dotgraph-release.tar.bz2
Source1: ros-rpmlintrc
Requires: python2-pydot
Requires: ros-melodic
Requires: ros-melodic-python-qt-binding >= 0.3.0
BuildRequires: python2-pygraphviz
BuildRequires: python2-setuptools
BuildRequires: ros-melodic
BuildRequires: ros-melodic-catkin
%description
qt_dotgraph provides helpers to work with dot graphs.
%prep
%autosetup -p0 -n qt_dotgraph-release
%build
# In case we're installing to a non-standard location, look for a setup.sh
# in the install tree that was dropped by catkin, and source it. It will
# set things like CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
if [ -f "/opt/ros/melodic/setup.sh" ]; then . "/opt/ros/melodic/setup.sh"; fi
mkdir -p obj-%{_target_platform} && cd obj-%{_target_platform}
cmake \
-UINCLUDE_INSTALL_DIR \
-ULIB_INSTALL_DIR \
-USYSCONF_INSTALL_DIR \
-USHARE_INSTALL_PREFIX \
-ULIB_SUFFIX \
-DCMAKE_INSTALL_LIBDIR="lib" \
-DCMAKE_INSTALL_PREFIX="/opt/ros/melodic" \
-DCMAKE_PREFIX_PATH="/opt/ros/melodic" \
-DSETUPTOOLS_DEB_LAYOUT=OFF \
-DCATKIN_BUILD_BINARY_PACKAGE="1" \
-DPYTHON_EXECUTABLE=/usr/bin/python \
..
%make_build
%install
# In case we're installing to a non-standard location, look for a setup.sh
# in the install tree that was dropped by catkin, and source it. It will
# set things like CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
if [ -f "/opt/ros/melodic/setup.sh" ]; then . "/opt/ros/melodic/setup.sh"; fi
%make_install -C obj-%{_target_platform}
%files
/opt/ros/melodic
%changelog