File rosbag.spec of Package rosbag

%global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
%global __provides_exclude_from ^/opt/ros/noetic/.*$
%global __requires_exclude_from ^/opt/ros/noetic/.*$

Name:           ros-noetic-rosbag
Version:        1.15.15
Release:        1%{?dist}
Summary:        ROS rosbag package

License:        BSD
Group:          Development/Libraries
URL:            http://wiki.ros.org/rosbag
Source0:        rosbag-release.tar.bz2
Source1:        ros-rpmlintrc
Requires:       libboost_date_time1_66_0-devel
Requires:       libboost_filesystem1_66_0-devel
Requires:       libboost_program_options1_66_0-devel
Requires:       libboost_regex1_66_0-devel
Requires:       libboost_thread1_66_0-devel
Requires:       python3-pycryptodomex
Requires:       python3-python-gnupg
Requires:       python3-rospkg
Requires:       ros-noetic
Requires:       ros-noetic-genmsg
Requires:       ros-noetic-genpy
Requires:       ros-noetic-rosbag-storage
Requires:       ros-noetic-rosconsole
Requires:       ros-noetic-roscpp
Requires:       ros-noetic-roslib
Requires:       ros-noetic-rospy
Requires:       ros-noetic-std-srvs
Requires:       ros-noetic-topic-tools
Requires:       ros-noetic-xmlrpcpp
BuildRequires:  libboost_date_time1_66_0-devel
BuildRequires:  libboost_filesystem1_66_0-devel
BuildRequires:  libboost_program_options1_66_0-devel
BuildRequires:  libboost_regex1_66_0-devel
BuildRequires:  libboost_thread1_66_0-devel
BuildRequires:  python3-Pillow
BuildRequires:  ros-noetic
BuildRequires:  ros-noetic-catkin >= 0.5.78
BuildRequires:  ros-noetic-cpp-common
BuildRequires:  ros-noetic-rosbag-storage
BuildRequires:  ros-noetic-rosconsole
BuildRequires:  ros-noetic-roscpp
BuildRequires:  ros-noetic-roscpp-serialization
BuildRequires:  ros-noetic-std-srvs
BuildRequires:  ros-noetic-topic-tools
BuildRequires:  ros-noetic-xmlrpcpp

%description
This is a set of tools for recording from and playing back to ROS topics. It is
intended to be high performance and avoids deserialization and reserialization
of the messages.

%prep
%autosetup -p0 -n rosbag-release

%build
# In case we're installing to a non-standard location, look for a setup.sh
# in the install tree that was dropped by catkin, and source it.  It will
# set things like CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
if [ -f "/opt/ros/noetic/setup.sh" ]; then . "/opt/ros/noetic/setup.sh"; fi
mkdir -p obj-%{_target_platform} && cd obj-%{_target_platform}
cmake \
    -UINCLUDE_INSTALL_DIR \
    -ULIB_INSTALL_DIR \
    -USYSCONF_INSTALL_DIR \
    -USHARE_INSTALL_PREFIX \
    -ULIB_SUFFIX \
    -DCMAKE_INSTALL_LIBDIR="lib" \
    -DCMAKE_INSTALL_PREFIX="/opt/ros/noetic" \
    -DCMAKE_PREFIX_PATH="/opt/ros/noetic" \
    -DSETUPTOOLS_DEB_LAYOUT=OFF \
    -DCATKIN_BUILD_BINARY_PACKAGE="1" \
    -DPYTHON_EXECUTABLE=/usr/bin/python3 \
    ..

%make_build

%install
# In case we're installing to a non-standard location, look for a setup.sh
# in the install tree that was dropped by catkin, and source it.  It will
# set things like CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
if [ -f "/opt/ros/noetic/setup.sh" ]; then . "/opt/ros/noetic/setup.sh"; fi
%make_install -C obj-%{_target_platform}

%files
/opt/ros/noetic

%changelog
openSUSE Build Service is sponsored by