File diagnostic_analysis.spec of Package diagnostic_analysis
%global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
%global __provides_exclude_from ^/opt/ros/noetic/.*$
%global __requires_exclude_from ^/opt/ros/noetic/.*$
Name: ros-noetic-diagnostic-analysis
Version: 1.11.0
Release: 1%{?dist}
Summary: ROS diagnostic_analysis package
License: BSD
Group: Development/Libraries
URL: http://www.ros.org/wiki/diagnostics_analysis
Source0: diagnostic_analysis-release.tar.bz2
Source1: ros-rpmlintrc
BuildArch: noarch
Requires: ros-noetic
Requires: ros-noetic-diagnostic-msgs
Requires: ros-noetic-rosbag
Requires: ros-noetic-roslib
BuildRequires: ros-noetic
BuildRequires: ros-noetic-catkin >= 0.5.68
BuildRequires: ros-noetic-diagnostic-msgs
BuildRequires: ros-noetic-rosbag
BuildRequires: ros-noetic-roslib
BuildRequires: ros-noetic-rostest
%description
The diagnostic_analysis package can convert a log of diagnostics data into a
series of CSV files. Robot logs are recorded with rosbag, and can be processed
offline using the scripts in this package.
%prep
%autosetup -p0 -n diagnostic_analysis-release
%build
# In case we're installing to a non-standard location, look for a setup.sh
# in the install tree that was dropped by catkin, and source it. It will
# set things like CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
if [ -f "/opt/ros/noetic/setup.sh" ]; then . "/opt/ros/noetic/setup.sh"; fi
mkdir -p obj-%{_target_platform} && cd obj-%{_target_platform}
cmake \
-UINCLUDE_INSTALL_DIR \
-ULIB_INSTALL_DIR \
-USYSCONF_INSTALL_DIR \
-USHARE_INSTALL_PREFIX \
-ULIB_SUFFIX \
-DCMAKE_INSTALL_LIBDIR="lib" \
-DCMAKE_INSTALL_PREFIX="/opt/ros/noetic" \
-DCMAKE_PREFIX_PATH="/opt/ros/noetic" \
-DSETUPTOOLS_DEB_LAYOUT=OFF \
-DCATKIN_BUILD_BINARY_PACKAGE="1" \
-DPYTHON_EXECUTABLE=/usr/bin/python3 \
..
%make_build
%install
# In case we're installing to a non-standard location, look for a setup.sh
# in the install tree that was dropped by catkin, and source it. It will
# set things like CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
if [ -f "/opt/ros/noetic/setup.sh" ]; then . "/opt/ros/noetic/setup.sh"; fi
%make_install -C obj-%{_target_platform}
%files
/opt/ros/noetic
%changelog