File image_proc.spec of Package image_proc

%global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
%global __provides_exclude_from ^/opt/ros/noetic/.*$
%global __requires_exclude_from ^/opt/ros/noetic/.*$

Name:           ros-noetic-image-proc
Version:        1.17.0
Release:        1%{?dist}
Summary:        ROS image_proc package

License:        BSD
Group:          Development/Libraries
URL:            http://www.ros.org/wiki/image_proc
Source0:        image_proc-release.tar.bz2
Source1:        ros-rpmlintrc
Requires:       ros-noetic
Requires:       ros-noetic-cv-bridge
Requires:       ros-noetic-dynamic-reconfigure
Requires:       ros-noetic-image-geometry
Requires:       ros-noetic-image-transport
Requires:       ros-noetic-nodelet
Requires:       ros-noetic-nodelet-topic-tools
Requires:       ros-noetic-roscpp
Requires:       ros-noetic-sensor-msgs
BuildRequires:  libboost_atomic1_66_0-devel
BuildRequires:  libboost_chrono1_66_0-devel
BuildRequires:  libboost_date_time1_66_0-devel
BuildRequires:  libboost_filesystem1_66_0-devel
BuildRequires:  libboost_headers1_66_0-devel
BuildRequires:  libboost_iostreams1_66_0-devel
BuildRequires:  libboost_program_options1_66_0-devel
BuildRequires:  libboost_python-py2_7-1_66_0-devel
BuildRequires:  libboost_python-py3-1_66_0-devel
BuildRequires:  libboost_regex1_66_0-devel
BuildRequires:  libboost_serialization1_66_0-devel
BuildRequires:  libboost_signals1_66_0-devel
BuildRequires:  libboost_system1_66_0-devel
BuildRequires:  libboost_thread1_66_0-devel
BuildRequires:  ros-noetic
BuildRequires:  ros-noetic-camera-calibration-parsers
BuildRequires:  ros-noetic-catkin >= 0.5.68
BuildRequires:  ros-noetic-cv-bridge
BuildRequires:  ros-noetic-dynamic-reconfigure
BuildRequires:  ros-noetic-image-geometry
BuildRequires:  ros-noetic-image-transport
BuildRequires:  ros-noetic-nodelet
BuildRequires:  ros-noetic-nodelet-topic-tools
BuildRequires:  ros-noetic-roscpp
BuildRequires:  ros-noetic-rostest
BuildRequires:  ros-noetic-sensor-msgs

%description
Single image rectification and color processing.

%prep
%autosetup -p0 -n image_proc-release

%build
# In case we're installing to a non-standard location, look for a setup.sh
# in the install tree that was dropped by catkin, and source it.  It will
# set things like CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
if [ -f "/opt/ros/noetic/setup.sh" ]; then . "/opt/ros/noetic/setup.sh"; fi
mkdir -p obj-%{_target_platform} && cd obj-%{_target_platform}
cmake \
    -UINCLUDE_INSTALL_DIR \
    -ULIB_INSTALL_DIR \
    -USYSCONF_INSTALL_DIR \
    -USHARE_INSTALL_PREFIX \
    -ULIB_SUFFIX \
    -DCMAKE_INSTALL_LIBDIR="lib" \
    -DCMAKE_INSTALL_PREFIX="/opt/ros/noetic" \
    -DCMAKE_PREFIX_PATH="/opt/ros/noetic" \
    -DSETUPTOOLS_DEB_LAYOUT=OFF \
    -DCATKIN_BUILD_BINARY_PACKAGE="1" \
    -DPYTHON_EXECUTABLE=/usr/bin/python3 \
    ..

%make_build

%install
# In case we're installing to a non-standard location, look for a setup.sh
# in the install tree that was dropped by catkin, and source it.  It will
# set things like CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
if [ -f "/opt/ros/noetic/setup.sh" ]; then . "/opt/ros/noetic/setup.sh"; fi
%make_install -C obj-%{_target_platform}

%files
/opt/ros/noetic

%changelog
openSUSE Build Service is sponsored by