File rqt_robot_plugins.spec of Package rqt_robot_plugins
%global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
%global __provides_exclude_from ^/opt/ros/melodic/.*$
%global __requires_exclude_from ^/opt/ros/melodic/.*$
Name: ros-melodic-rqt-robot-plugins
Version: 0.5.7
Release: 0%{?dist}
Summary: ROS rqt_robot_plugins package
License: BSD
Group: Development/Libraries
URL: http://ros.org/wiki/rqt_robot_plugins
Source0: rqt_robot_plugins-release.tar.bz2
Source1: ros-rpmlintrc
Requires: ros-melodic-rqt-moveit
Requires: ros-melodic-rqt-nav-view
Requires: ros-melodic-rqt-pose-view
Requires: ros-melodic-rqt-robot-dashboard
Requires: ros-melodic-rqt-robot-monitor
Requires: ros-melodic-rqt-robot-steering
Requires: ros-melodic-rqt-runtime-monitor
Requires: ros-melodic-rqt-rviz
Requires: ros-melodic-rqt-tf-tree
BuildRequires: ros-melodic-catkin
%description
Metapackage of rqt plugins that are particularly used with robots during its
operation. To run any rqt plugins, just type in a single command
"rqt", then select any plugins you want from the GUI that launches
afterwards. rqt consists of three following metapackages: rqt - provides a
container window where all rqt tools can be docked at. rqt plugin developers
barely needs to pay attention. rqt_common_plugins - ROS backend tools suite that
can be used on/off of robot runtime. rqt_robot_plugins (You're here!)
%prep
%autosetup -n rqt_robot_plugins-release
%build
# In case we're installing to a non-standard location, look for a setup.sh
# in the install tree that was dropped by catkin, and source it. It will
# set things like CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
if [ -f "/opt/ros/melodic/setup.sh" ]; then . "/opt/ros/melodic/setup.sh"; fi
mkdir -p obj-%{_target_platform} && cd obj-%{_target_platform}
cmake \
-UINCLUDE_INSTALL_DIR \
-ULIB_INSTALL_DIR \
-USYSCONF_INSTALL_DIR \
-USHARE_INSTALL_PREFIX \
-ULIB_SUFFIX \
-DCMAKE_INSTALL_LIBDIR="lib" \
-DCMAKE_INSTALL_PREFIX="/opt/ros/melodic" \
-DCMAKE_PREFIX_PATH="/opt/ros/melodic" \
-DSETUPTOOLS_DEB_LAYOUT=OFF \
-DCATKIN_BUILD_BINARY_PACKAGE="1" \
-DPYTHON_EXECUTABLE=/usr/bin/python \
..
%make_build
%install
# In case we're installing to a non-standard location, look for a setup.sh
# in the install tree that was dropped by catkin, and source it. It will
# set things like CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
if [ -f "/opt/ros/melodic/setup.sh" ]; then . "/opt/ros/melodic/setup.sh"; fi
%make_install -C obj-%{_target_platform}
%files
/opt/ros/melodic
%changelog
* Sat Sep 11 2021 Aaron Blasdel <ablasdel@gmail.com> - 0.5.7-0
- Autogenerated by rossuse