File qt_gui_cpp.spec of Package qt_gui_cpp
%global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
%global __provides_exclude_from ^/opt/ros/melodic/.*$
%global __requires_exclude_from ^/opt/ros/melodic/.*$
Name: ros-melodic-qt-gui-cpp
Version: 0.4.2
Release: 1%{?dist}
Summary: ROS qt_gui_cpp package
License: BSD
Group: Development/Libraries
URL: http://ros.org/wiki/qt_gui_cpp
Source0: qt_gui_cpp-release.tar.bz2
Source1: ros-rpmlintrc
Requires: ros-melodic-pluginlib >= 1.9.23
Requires: ros-melodic-qt-gui >= 0.3.0
Requires: tinyxml-devel
BuildRequires: libqt5-qtbase-common-devel
BuildRequires: libqt5-qtbase-devel
BuildRequires: pkg-config
BuildRequires: python2-setuptools
BuildRequires: ros-melodic-catkin
BuildRequires: ros-melodic-cmake-modules
BuildRequires: ros-melodic-pluginlib >= 1.9.23
BuildRequires: ros-melodic-python-qt-binding >= 0.3.0
BuildRequires: tinyxml-devel
BuildRequires: python2-sip-devel
%description
qt_gui_cpp provides the foundation for C++-bindings for qt_gui and creates
bindings for every generator available. At least one specific binding must be
available in order to use C++-plugins.
%prep
%autosetup -n qt_gui_cpp-release
%build
# In case we're installing to a non-standard location, look for a setup.sh
# in the install tree that was dropped by catkin, and source it. It will
# set things like CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
if [ -f "/opt/ros/melodic/setup.sh" ]; then . "/opt/ros/melodic/setup.sh"; fi
mkdir -p obj-%{_target_platform} && cd obj-%{_target_platform}
cmake \
-UINCLUDE_INSTALL_DIR \
-ULIB_INSTALL_DIR \
-USYSCONF_INSTALL_DIR \
-USHARE_INSTALL_PREFIX \
-ULIB_SUFFIX \
-DCMAKE_INSTALL_LIBDIR="lib" \
-DCMAKE_INSTALL_PREFIX="/opt/ros/melodic" \
-DCMAKE_PREFIX_PATH="/opt/ros/melodic" \
-DSETUPTOOLS_DEB_LAYOUT=OFF \
-DCATKIN_BUILD_BINARY_PACKAGE="1" \
-DPYTHON_EXECUTABLE=/usr/bin/python \
..
%make_build
%install
# In case we're installing to a non-standard location, look for a setup.sh
# in the install tree that was dropped by catkin, and source it. It will
# set things like CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
if [ -f "/opt/ros/melodic/setup.sh" ]; then . "/opt/ros/melodic/setup.sh"; fi
%make_install -C obj-%{_target_platform}
%files
/opt/ros/melodic
%changelog
* Sat Sep 11 2021 Dirk Thomas <dthomas@osrfoundation.org> - 0.4.2-1
- Autogenerated by rossuse