File image_rotate.spec of Package image_rotate
%global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
%global __provides_exclude_from ^/opt/ros/melodic/.*$
%global __requires_exclude_from ^/opt/ros/melodic/.*$
Name: ros-melodic-image-rotate
Version: 1.15.0
Release: 1%{?dist}
Summary: ROS image_rotate package
License: BSD
Group: Development/Libraries
URL: http://ros.org/wiki/image_rotate
Source0: image_rotate-release.tar.bz2
Source1: ros-rpmlintrc
Requires: ros-melodic
Requires: ros-melodic-cv-bridge
Requires: ros-melodic-dynamic-reconfigure
Requires: ros-melodic-image-transport
Requires: ros-melodic-nodelet
Requires: ros-melodic-roscpp
Requires: ros-melodic-tf2
Requires: ros-melodic-tf2-geometry-msgs
Requires: ros-melodic-tf2-ros
BuildRequires: ros-melodic
BuildRequires: ros-melodic-catkin
BuildRequires: ros-melodic-cmake-modules
BuildRequires: ros-melodic-cv-bridge
BuildRequires: ros-melodic-dynamic-reconfigure
BuildRequires: ros-melodic-geometry-msgs
BuildRequires: ros-melodic-image-transport
BuildRequires: ros-melodic-nodelet
BuildRequires: ros-melodic-roscpp
BuildRequires: ros-melodic-rostest
BuildRequires: ros-melodic-tf2
BuildRequires: ros-melodic-tf2-geometry-msgs
BuildRequires: ros-melodic-tf2-ros
%description
Contains a node that rotates an image stream in a way that minimizes the angle
between a vector in some arbitrary frame and a vector in the camera frame. The
frame of the outgoing image is published by the node. This node is intended to
allow camera images to be visualized in an orientation that is more intuitive
than the hardware-constrained orientation of the physical camera. This is
particularly helpful, for example, to show images from the PR2's forearm cameras
with a consistent up direction, despite the fact that the forearms need to
rotate in arbitrary ways during manipulation. It is not recommended to use the
output from this node for further computation, as it interpolates the source
image, introduces black borders, and does not output a camera_info.
%prep
%autosetup -n image_rotate-release
%build
# In case we're installing to a non-standard location, look for a setup.sh
# in the install tree that was dropped by catkin, and source it. It will
# set things like CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
if [ -f "/opt/ros/melodic/setup.sh" ]; then . "/opt/ros/melodic/setup.sh"; fi
mkdir -p obj-%{_target_platform} && cd obj-%{_target_platform}
cmake \
-UINCLUDE_INSTALL_DIR \
-ULIB_INSTALL_DIR \
-USYSCONF_INSTALL_DIR \
-USHARE_INSTALL_PREFIX \
-ULIB_SUFFIX \
-DCMAKE_INSTALL_LIBDIR="lib" \
-DCMAKE_INSTALL_PREFIX="/opt/ros/melodic" \
-DCMAKE_PREFIX_PATH="/opt/ros/melodic" \
-DSETUPTOOLS_DEB_LAYOUT=OFF \
-DCATKIN_BUILD_BINARY_PACKAGE="1" \
-DPYTHON_EXECUTABLE=/usr/bin/python \
..
%make_build
%install
# In case we're installing to a non-standard location, look for a setup.sh
# in the install tree that was dropped by catkin, and source it. It will
# set things like CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
if [ -f "/opt/ros/melodic/setup.sh" ]; then . "/opt/ros/melodic/setup.sh"; fi
%make_install -C obj-%{_target_platform}
%files
/opt/ros/melodic
%changelog