File tf.spec of Package tf

%global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
%global __provides_exclude_from ^/opt/ros/melodic/.*$
%global __requires_exclude_from ^/opt/ros/melodic/.*$

Name:           ros-melodic-tf
Version:        1.12.1
Release:        1%{?dist}
Summary:        ROS tf package

License:        BSD
Group:          Development/Libraries
URL:            http://www.ros.org/wiki/tf
Source0:        tf-release.tar.bz2
Source1:        ros-rpmlintrc

Requires:       graphviz
Requires:       ros-melodic
Requires:       ros-melodic-geometry-msgs
Requires:       ros-melodic-message-filters >= 1.11.1
Requires:       ros-melodic-message-runtime
Requires:       ros-melodic-rosconsole
Requires:       ros-melodic-roscpp
Requires:       ros-melodic-roswtf
Requires:       ros-melodic-sensor-msgs
Requires:       ros-melodic-std-msgs
Requires:       ros-melodic-tf2-ros >= 0.5.16
BuildRequires:  ros-melodic
BuildRequires:  ros-melodic-angles
BuildRequires:  ros-melodic-catkin >= 0.6.4
BuildRequires:  ros-melodic-geometry-msgs
BuildRequires:  ros-melodic-message-filters
BuildRequires:  ros-melodic-message-generation
BuildRequires:  ros-melodic-rosconsole
BuildRequires:  ros-melodic-roscpp
BuildRequires:  ros-melodic-rostest
BuildRequires:  ros-melodic-rostime
BuildRequires:  ros-melodic-rosunit
BuildRequires:  ros-melodic-sensor-msgs
BuildRequires:  ros-melodic-std-msgs
BuildRequires:  ros-melodic-tf2-ros >= 0.5.16

%description
tf is a package that lets the user keep track of multiple coordinate frames over
time. tf maintains the relationship between coordinate frames in a tree
structure buffered in time, and lets the user transform points, vectors, etc
between any two coordinate frames at any desired point in time. Migration: Since
ROS Hydro, tf has been "deprecated" in favor of tf2. tf2 is an
iteration on tf providing generally the same feature set more efficiently. As
well as adding a few new features. As tf2 is a major change the tf API has been
maintained in its current form. Since tf2 has a superset of the tf features with
a subset of the dependencies the tf implementation has been removed and replaced
with calls to tf2 under the hood. This will mean that all users will be
compatible with tf2. It is recommended for new work to use tf2 directly as it
has a cleaner interface. However tf will continue to be supported for through at
least J Turtle.

%prep
%autosetup -n tf-release


%build
# In case we're installing to a non-standard location, look for a setup.sh
# in the install tree that was dropped by catkin, and source it.  It will
# set things like CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
if [ -f "/opt/ros/melodic/setup.sh" ]; then . "/opt/ros/melodic/setup.sh"; fi
mkdir -p obj-%{_target_platform} && cd obj-%{_target_platform}
cmake \
    -UINCLUDE_INSTALL_DIR \
    -ULIB_INSTALL_DIR \
    -USYSCONF_INSTALL_DIR \
    -USHARE_INSTALL_PREFIX \
    -ULIB_SUFFIX \
    -DCMAKE_INSTALL_LIBDIR="lib" \
    -DCMAKE_INSTALL_PREFIX="/opt/ros/melodic" \
    -DCMAKE_PREFIX_PATH="/opt/ros/melodic" \
    -DSETUPTOOLS_DEB_LAYOUT=OFF \
    -DCATKIN_BUILD_BINARY_PACKAGE="1" \
    -DPYTHON_EXECUTABLE=/usr/bin/python \
    ..

%make_build

%install
# In case we're installing to a non-standard location, look for a setup.sh
# in the install tree that was dropped by catkin, and source it.  It will
# set things like CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
if [ -f "/opt/ros/melodic/setup.sh" ]; then . "/opt/ros/melodic/setup.sh"; fi
%make_install -C obj-%{_target_platform}

%files
/opt/ros/melodic

%changelog
openSUSE Build Service is sponsored by