File ds9.spec of Package ds9
#
# spec file for package ds9
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%if 0%{?is_opensuse}
#https://github.com/openSUSE/rpm-config-SUSE/issues/50
%define _lto_cflags %{nil}
%endif
Name: ds9
Version: 8.6
Release: 0
License: GPL-3.0+
Summary: SAOImage DS9 Astronomical Imaging Application
Url: http://ds9.si.edu
Source: http://ds9.si.edu/download/source/ds9.%{version}.tar.gz
# PATCH-FIX-OPENSUSE: Fix openSUSE fatal GCC errors.
Patch1: no-return-in-nonvoid-function.patch
Group: Productivity/Scientific/Astronomy
BuildRequires: make
BuildRequires: automake
BuildRequires: autoconf
BuildRequires: gcc
BuildRequires: gcc-c++
BuildRequires: libX11-devel
BuildRequires: libXt-devel
BuildRequires: zlib-devel
BuildRequires: libxml2-devel
BuildRequires: libxslt-devel
BuildRequires: libXft-devel
BuildRequires: zip
%if 0%{?fedora_version}
BuildRequires: libXScrnSaver-devel
BuildRequires: mesa-libGLU-devel
%else
BuildRequires: libXss-devel
BuildRequires: glu-devel
%endif
Requires: bash
%description
SAOImage DS9 is an astronomical imaging and data visualization application. DS9
supports FITS images and binary tables, multiple frame buffers, region
manipulation, and many scale algorithms and colormaps. It provides for easy
communication with external analysis tasks and is highly configurable and
extensible via XPA and SAMP.
It is a stand-alone application. It requires no installation or support files.
All versions and platforms support a consistent set of GUI and functional
capabilities.
It supports advanced features such as 2-D, 3-D and RGB frame buffers, mosaic
images, tiling, blinking, geometric markers, colormap manipulation, scaling,
arbitrary zoom, cropping, rotation, pan, and a variety of coordinate systems.
The GUI is user configurable. GUI elements such as the coordinate
display, panner, magnifier, horizontal and vertical graphs, button bar, and
color bar can be configured via menus or the command line.
%prep
%setup -q -n SAOImageDS9
%patch -P1 -p1
%build
#https://github.com/SAOImageDS9/SAOImageDS9/issues/134
sed -i 's/tclsh/$(TCLSH_PROG)/' ds9/make.include
%define _configure unix/configure
%ifarch ppc64
sed -i '/SSLCONFIG/s@$@; \\\n\t./Configure linux-ppc64@' make.include
%endif
%if 0%{?fedora_version}
%global ofla %(echo %optflags | sed 's/-Werror=format-security//' )
%define optflags %{expand:%ofla}
%global debug_package %{nil}
%endif
#as of 20240815 tumbleweed need this
%ifarch %{ix86}
export CFLAGS="%{optflags} -D_LARGEFILE64_SOURCE"
%endif
#keep the default value for includedir
%configure --includedir='${prefix}/include'
%make_build
%install
install -D -m0755 bin/ds9 "%{buildroot}/%{_bindir}/ds9"
%files
%license LICENSE
%doc ds9/doc/*
%{_bindir}/ds9
%changelog