File python-cloudkittyclient.spec of Package python-cloudkittyclient
#
# spec file for package python-cloudkittyclient
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: python-cloudkittyclient
Version: 5.0.0
Release: 0
Summary: Python API for OpenStack Cloudkitty
License: Apache-2.0
Group: Development/Languages/Python
URL: https://docs.openstack.org/python-cloudkittyclient
Source0: https://files.pythonhosted.org/packages/source/p/python-cloudkittyclient/python-cloudkittyclient-5.0.0.tar.gz
BuildRequires: openstack-macros
BuildRequires: python3-PrettyTable
BuildRequires: python3-cliff
BuildRequires: python3-fixtures
BuildRequires: python3-keystoneclient
BuildRequires: python3-oslo.i18n
BuildRequires: python3-oslo.log
BuildRequires: python3-oslo.serialization
BuildRequires: python3-oslo.utils
BuildRequires: python3-oslotest
BuildRequires: python3-pbr
BuildRequires: python3-python-subunit
BuildRequires: python3-stestr
BuildRequires: python3-testscenarios
BuildRequires: python3-testtools
BuildArch: noarch
%description
This is a client library for CloudKitty built on the CloudKitty API.
It provides a Python API (the cloudkittyclient module).
%package -n python3-cloudkittyclient
Summary: Python API for OpenStack Cloudkitty
Requires: python3-Babel
Requires: python3-PrettyTable
Requires: python3-cliff
Requires: python3-keystoneclient
Requires: python3-openstackclient
Requires: python3-oslo.i18n
Requires: python3-oslo.log
Requires: python3-oslo.serialization
Requires: python3-oslo.utils
Requires: python3-pbr
Requires: python3-six
Requires: python3-stevedore
%if 0%{?suse_version}
Requires(post): update-alternatives
Requires(postun): update-alternatives
%else
# on RDO, update-alternatives is in chkconfig
Requires(post): chkconfig
Requires(postun): chkconfig
%endif
%description -n python3-cloudkittyclient
This is a client library for CloudKitty built on the CloudKitty API.
It provides a Python API (the cloudkittyclient module).
This package contains the Python 3.x module
%package -n python-cloudkittyclient-doc
Summary: Documentation for OpenStack Cloudkitty API client libary
Group: Documentation/HTML
BuildRequires: python3-Sphinx
BuildRequires: python3-openstackdocstheme
BuildRequires: python3-sphinxcontrib-svg2pdfconverter
%description -n python-cloudkittyclient-doc
This is a client library for CloudKitty built on the CloudKitty API.
It provides a Python API (the cloudkittyclient module).
This package contains the documentation.
%prep
%autosetup -p1 -n python-cloudkittyclient-5.0.0
%py_req_cleanup
sed -i 's/^warning-is-error.*/warning-is-error = 0/g' setup.cfg
%build
%{py3_build}
# Build HTML docs and man page
PBR_VERSION=5.0.0 PYTHONPATH=. %sphinx_build -b html doc/source doc/build/html
# remove the Sphinx-build leftovers
rm -rf doc/build/html/.{doctrees,buildinfo}
%install
%{py3_install}
%check
%{openstack_stestr_run}
%files -n python3-cloudkittyclient
%doc README.rst
%license LICENSE
%{python3_sitelib}/cloudkittyclient
%{python3_sitelib}/*.egg-info
%{_bindir}/cloudkitty
%files -n python-cloudkittyclient-doc
%doc doc/build/html
%license LICENSE
%changelog