File python-taskflow.spec of Package python-taskflow
#
# spec file for package python-taskflow
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: python-taskflow
Version: 5.9.1
Release: 0
Summary: Taskflow structured state management library
License: Apache-2.0
Group: Development/Languages/Python
URL: https://docs.openstack.org/taskflow
Source0: https://files.pythonhosted.org/packages/source/t/taskflow/taskflow-5.9.1.tar.gz
BuildRequires: openstack-macros
BuildRequires: python3-PyMySQL
BuildRequires: python3-SQLAlchemy
BuildRequires: python3-SQLAlchemy-Utils
BuildRequires: python3-alembic
BuildRequires: python3-automaton
BuildRequires: python3-cachetools
BuildRequires: python3-eventlet
BuildRequires: python3-fasteners
BuildRequires: python3-futurist
BuildRequires: python3-jsonschema
BuildRequires: python3-kazoo
BuildRequires: python3-kombu
BuildRequires: python3-networkx
BuildRequires: python3-oslo.serialization
BuildRequires: python3-oslo.utils
BuildRequires: python3-oslotest
BuildRequires: python3-pbr
BuildRequires: python3-psycopg2
BuildRequires: python3-pydot
BuildRequires: python3-redis
BuildRequires: python3-retrying
BuildRequires: python3-stestr
BuildRequires: python3-stevedore
BuildRequires: python3-tenacity
BuildRequires: python3-testrepository
BuildRequires: python3-testscenarios
BuildRequires: python3-testtools
BuildRequires: python3-zake
BuildArch: noarch
%description
A library to do [jobs, tasks, flows] in a HA manner using
different backends to be used with OpenStack projects.
%package -n python3-taskflow
Summary: Taskflow structured state management library
Requires: python3-automaton
Requires: python3-cachetools
Requires: python3-debtcollector
Requires: python3-fasteners
Requires: python3-futurist
Requires: python3-jsonschema
Requires: python3-kazoo
Requires: python3-networkx
Requires: python3-oslo.serialization
Requires: python3-oslo.utils
Requires: python3-six
Requires: python3-stevedore
Requires: python3-tenacity
%description -n python3-taskflow
A library to do [jobs, tasks, flows] in a HA manner using
different backends to be used with OpenStack projects.
This package contains the Python 3.x module.
%package -n python-taskflow-doc
Summary: Documentation for Taskflow
Group: Documentation/HTML
BuildRequires: python3-Sphinx
BuildRequires: python3-openstackdocstheme
%description -n python-taskflow-doc
A library to do [jobs, tasks, flows] in a HA manner using
different backends to be used with OpenStack projects.
This package contains the associated documentation.
%prep
%autosetup -p1 -n taskflow-5.9.1
%py_req_cleanup
%build
%{py3_build}
%install
%{py3_install}
# generate html docs
PBR_VERSION=5.9.1 %sphinx_build -b html doc/source doc/build/html
# remove the sphinx-build leftovers
rm -rf doc/build/html/.{doctrees,buildinfo}
%check
%{openstack_stestr_run}
%files -n python3-taskflow
%doc README.rst
%license LICENSE
%{python3_sitelib}/taskflow
%{python3_sitelib}/taskflow-*.egg-info
%files -n python-taskflow-doc
%license LICENSE
%doc doc/build/html
%changelog