File perl-Fuse.spec of Package perl-Fuse
#
# spec file for package perl-Fuse
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define cpan_name Fuse
Name: perl-Fuse
Version: 0.160.0
Release: 0
# 0.16 -> normalize -> 0.160.0
%define cpan_version 0.16
License: LGPL-2.1-or-later
Summary: Write filesystems in Perl using FUSE
URL: https://metacpan.org/release/%{cpan_name}
Source0: https://cpan.metacpan.org/authors/id/D/DP/DPATES/%{cpan_name}-%{cpan_version}.tar.gz
BuildRequires: perl
BuildRequires: perl-macros
BuildRequires: perl(Filesys::Statvfs)
BuildRequires: perl(Lchown)
BuildRequires: perl(Unix::Mknod)
Requires: perl(Filesys::Statvfs)
Requires: perl(Lchown)
Requires: perl(Unix::Mknod)
Provides: perl(Fuse) = %{version}
%undefine __perllib_provides
%{perl_requires}
%description
This lets you implement filesystems in perl, through the FUSE (Filesystem
in USErspace) kernel/lib interface.
FUSE expects you to implement callbacks for the various functions.
In the following definitions, "errno" can be 0 (for a success), -EINVAL,
-ENOENT, -EONFIRE, any integer less than 1 really.
You can import standard error constants by saying something like "use POSIX
qw(EDOTDOT ENOANO);".
Every constant you need (file types, open() flags, error values, etc) can
be imported either from POSIX or from Fcntl, often both. See their
respective documentations, for more information.
%prep
%autosetup -n %{cpan_name}-%{cpan_version}
find . -type f ! -path "*/t/*" ! -name "*.pl" ! -path "*/bin/*" ! -path "*/script/*" ! -path "*/scripts/*" ! -name "configure" -print0 | xargs -0 chmod 644
%build
perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
%make_build
%check
make test
%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist
%files -f %{name}.files
%doc AUTHORS Changes examples README
%changelog