File asl.spec of Package asl
#
# spec file for package asl (Version 1.42build35)
#
# Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
# norootforbuild
Name: asl
BuildRequires: gcc-c++ libpng texlive-latex xorg-x11 xorg-x11-devel
Url: http://john.ccac.rwth-aachen.de:8000/as/index.html
Version: 1.42build35
Release: 243
Group: Development/Languages/Other
License: GPLv2+
Summary: Macro Assembler AS
Source: asl-current-142-bld35.tar.bz2
Patch: asl-current.dif
Patch1: asl-ppc64.patch
Patch2: asl-DESTDIR.patch
Patch3: asl-gcc4.patch
Patch4: asl-hppa.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
AS is a portable macro cross-assembler for a variety of microprocessors
and controllers. Although it is mainly targeted at embedded processors
and single-board computers, you also find CPU families that are used in
workstations and PCs in the target list.
Authors:
--------
Alfred Arnold <alfred@ccac.rwth-aachen.de>
%prep
%setup -q -n asl-current
%patch
%patch1 -p1
%patch2 -p1
%patch3 -p0
%patch4 -p1
%build
make CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
make CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" docs
if test "$ABUILD_RUN_TEST_SUITES" = true ; then
make test
fi
%install
make install DESTDIR=$RPM_BUILD_ROOT
%files
%defattr(-,root,root)
%doc COPYING README README.LANGS TODO BENCHES
%doc doc/as-EN.txt doc/as-EN.html doc/as-EN.ps doc/as-EN.dvi
%doc doc/as-DE.txt doc/as-DE.html doc/as-DE.ps doc/as-DE.dvi
/usr/bin/asl
/usr/bin/alink
/usr/bin/p2bin
/usr/bin/p2hex
/usr/bin/pbind
/usr/bin/plist
%dir /usr/include/asl
/usr/include/asl/80c50x.inc
/usr/include/asl/80c552.inc
/usr/include/asl/bitfuncs.inc
/usr/include/asl/ctype.inc
/usr/include/asl/h8_3048.inc
/usr/include/asl/reg166.inc
/usr/include/asl/reg251.inc
/usr/include/asl/reg29k.inc
/usr/include/asl/reg53x.inc
/usr/include/asl/reg683xx.inc
/usr/include/asl/reg7000.inc
/usr/include/asl/reg78k0.inc
/usr/include/asl/reg96.inc
/usr/include/asl/regace.inc
/usr/include/asl/regavr.inc
/usr/include/asl/regcop8.inc
/usr/include/asl/reggp32.inc
/usr/include/asl/reghc12.inc
/usr/include/asl/regm16c.inc
/usr/include/asl/regmsp.inc
/usr/include/asl/regst9.inc
/usr/include/asl/regz380.inc
/usr/include/asl/stddef04.inc
/usr/include/asl/stddef16.inc
/usr/include/asl/stddef17.inc
/usr/include/asl/stddef18.inc
/usr/include/asl/stddef2x.inc
/usr/include/asl/stddef37.inc
/usr/include/asl/stddef3x.inc
/usr/include/asl/stddef47.inc
/usr/include/asl/stddef51.inc
/usr/include/asl/stddef56k.inc
/usr/include/asl/stddef5x.inc
/usr/include/asl/stddef60.inc
/usr/include/asl/stddef62.inc
/usr/include/asl/stddef75.inc
/usr/include/asl/stddef87.inc
/usr/include/asl/stddef90.inc
/usr/include/asl/stddef96.inc
/usr/include/asl/stddefxa.inc
/usr/include/asl/stddefz8.inc
%dir /usr/lib/asl
/usr/lib/asl/as.msg
/usr/lib/asl/alink.msg
/usr/lib/asl/cmdarg.msg
/usr/lib/asl/ioerrs.msg
/usr/lib/asl/p2bin.msg
/usr/lib/asl/p2hex.msg
/usr/lib/asl/pbind.msg
/usr/lib/asl/plist.msg
/usr/lib/asl/tools.msg
%doc %{_mandir}/man1/asl.1.gz
%doc %{_mandir}/man1/p2bin.1.gz
%doc %{_mandir}/man1/p2hex.1.gz
%doc %{_mandir}/man1/pbind.1.gz
%doc %{_mandir}/man1/plist.1.gz
%doc %{_mandir}/man1/alink.1.gz
%changelog