File go-mustache.go.spec of Package go-mustache.go
#
# spec file for package go-mustache.go
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
# Copyright (c), 2010, Sascha Peilicke <saschpe@gmx.de>
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: go-mustache.go
Version: 0.0.0+git20120208
Release: 1
Summary: The mustache template language in Go
Group: Development/Languages/Other
License: MIT
Url: http://github.com/hoisie/mustache.go
Source0: mustache.go-%{version}.tar.bz2
Patch0: opensuse-build-fix.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildRequires: go-devel
Recommends: go-mustache.go-doc
%{go_provides}
%{go_requires}
%{go_disable_brp_strip_static_archive}
%description
mustache.go is an implementation of the mustache template language in Go. It
is better suited for website templates than Go's native pkg/template.
mustache.go is fast, it parses templates efficiently and stores them in a
tree-like structure which allows for fast execution.
%package doc
Summary: API documenation
Group: Documentation/Other
Requires: %{name} = %{version}
%description doc
API, examples and documentation.
%prep
%setup -q -n mustache.go
%patch0 -p1
%build
%goprep github.com/hoisie/mustache.go
%gobuild /
%install
%goinstall
%godoc
%files
%defattr(-,root,root,-)
%doc LICENSE Readme.md
%{go_contribdir}/*
%files doc
%defattr(-,root,root,-)
%{go_contribsrcdir}/*
%changelog