File go-gocheck.spec of Package go-gocheck

#
# spec file for package go-gocheck
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
# Copyright (c) 2011 Sascha Peilicke <saschpe@gmx.de>
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           go-gocheck
Version:        2012.07.24
Release:        0
Summary:        Rich testing framework for the Go language
License:        BSD-3-Clause
Group:          Development/Languages/Other
Url:            http://labix.org/gocheck
Source:         gocheck-%{version}.tar.bz2
%define         go_import launchpad.net/gocheck
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  go-devel
%if 0%{?suse_version} >= 1100
Recommends:     go-gocheck-doc
%endif
%{go_disable_brp_strip_static_archive}
%{go_exclusivearch}
%{go_provides}
%{go_requires}

%description
The Go language provides an internal testing library, named "testing", which is
relatively slim due to the fact that the standard library correctness by itself
is verified using it. The gocheck package, on the other hand, expects the
standard library from Go to be working correctly, and builds on it to offer a
richer testing framework for libraries and applications to use.

It includes features such as:

 - Helpful error reporting to aid on figuring problems out (see below)
 - Richer test helpers: assertions which interrupt the test immediately,
 - deep multi-type comparisons, string matching, etc
 - Suite-based grouping of tests
 - Benchmarks integrated in the suite logic (with fixtures, etc)
 - Fixtures: per suite and/or per test set up and tear down
 - Management of temporary directories
 - Panic-catching logic, with proper error reporting
 - Proper counting of successes, failures, panics, missed tests, skips, etc
 - Explicit test skipping
 - Support for expected failures
 - Verbosity flag which disables output caching
 - Fully tested (yes, it manages to test itself reliably! :-)

%package doc
Summary:        API documenation
Group:          Documentation/Other
Requires:       %{name} = %{version}

%description doc
API, examples and documentation.

%prep
%setup -q -n gocheck

%build
%goprep  launchpad.net/gocheck
%gobuild

%install
%goinstall
%godoc

%files
%defattr(-,root,root,-)
%doc LICENSE TODO
%{go_contribdir}/*

%files doc
%defattr(-,root,root,-)
%{go_contribsrcdir}/*

%changelog
openSUSE Build Service is sponsored by