File kdevelop5-plugin-python3.spec of Package kdevelop5-plugin-python3
#
# spec file for package kdevelop5-plugin-python3
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%define rname kdev-python
%define rversion 5.1
Name: kdevelop5-plugin-python3
Version: 5.1.2
Release: 0
Summary: Python support for KDevelop
License: GPL-2.0+
Group: Development/Tools/IDE
Url: http://www.kdevelop.org
Source0: %{rname}-%{version}.tar.xz
BuildRequires: extra-cmake-modules
BuildRequires: fdupes
BuildRequires: grantlee5-devel
BuildRequires: karchive-devel
BuildRequires: kcmutils-devel
BuildRequires: kdevelop5 >= 5.0.0
BuildRequires: kdevplatform-devel >= 5.0.0
BuildRequires: kf5-filesystem
BuildRequires: kguiaddons-devel
BuildRequires: ki18n-devel
BuildRequires: kiconthemes-devel
BuildRequires: kitemmodels-devel
BuildRequires: knewstuff-devel
BuildRequires: knotifications-devel
BuildRequires: knotifyconfig-devel
BuildRequires: ktexteditor-devel
BuildRequires: kwindowsystem-devel
BuildRequires: pkgconfig
BuildRequires: python3 >= 3.4.3
BuildRequires: python3-devel >= 3.4.3
BuildRequires: threadweaver-devel
BuildRequires: pkgconfig(Qt5Concurrent) >= 5.2.0
BuildRequires: pkgconfig(Qt5Quick) >= 5.2.0
BuildRequires: pkgconfig(Qt5Test) >= 5.2.0
BuildRequires: pkgconfig(Qt5Widgets) >= 5.2.0
Requires: kdevelop5
Requires: python-qt5
Recommends: %{name}-lang
Recommends: python3-pep8
Provides: kdevelop4-plugin-python = %{version}
Obsoletes: kdevelop4-plugin-python < %{version}
# The following are needed due to old unstable packages in KDE repositories
Provides: kdevelop4-plugin-python3 = %{version}
Obsoletes: kdevelop4-plugin-python3 < %{version}
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
A KDevelop plugin which provides Python language support, including code completion and debugging using PDB.
%package lang
Summary: Languages for package %{name}
Group: System/Localization
Requires: %{name} = %{version}
Provides: %{name}-lang-all = %{version}
Supplements: packageand(bundle-lang-other:%{name})
BuildArch: noarch
Conflicts: kdevelop4-plugin-python-lang
%description lang
Provides translations to the package %{name}
%prep
%setup -q -n %{rname}-%{version}
%build
%cmake_kf5 -d build
make %{?_smp_mflags} parser
%make_jobs
%install
%kf5_makeinstall -C build
%find_lang kdevpython %{name}.lang
%fdupes -s %{buildroot}
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
%doc README
%{_kf5_libdir}/libkdev*python*.so*
%{_kf5_plugindir}/
%{_kf5_sharedir}/kdevappwizard/
%{_kf5_sharedir}/kdevpythonsupport/
%files lang -f %{name}.lang
%defattr(-,root,root)
%changelog