File dolphin.spec of Package dolphin

#
# spec file for package dolphin
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%bcond_without lang

Name:           dolphin
Version:        17.04.2
Release:        0
%define kf5_version 5.26.0
# Latest stable Applications (e.g. 16.08 in KA, but 16.11.80 in KUA)
%{!?_kapp_version: %global _kapp_version %(echo %{version}| awk -F. '{print $1"."$2}')}
Summary:        KDE File Manager
License:        GPL-2.0+
Group:          Productivity/File utilities
Url:            http://www.kde.org
Source:         dolphin-%{version}.tar.xz
Source1:        dolphinsu.desktop
Patch0:         dolphin-go_up.diff
# PATCH-FIX-OPENSUSE
Patch1:         0001-Revert-Disallow-executing-Dolphin-as-root-on-Linux.patch
BuildRequires:  baloo5-devel
BuildRequires:  baloo5-widgets-devel
BuildRequires:  extra-cmake-modules >= 1.6.0
BuildRequires:  kactivities5-devel >= 5.7.0
BuildRequires:  kbookmarks-devel >= 5.7.0
BuildRequires:  kcmutils-devel >= 5.7.0
BuildRequires:  kcompletion-devel >= 5.7.0
BuildRequires:  kconfig-devel >= 5.7.0
BuildRequires:  kcoreaddons-devel >= 5.7.0
BuildRequires:  kcrash-devel
BuildRequires:  kdbusaddons-devel >= 5.7.0
BuildRequires:  kdoctools-devel >= 5.7.0
BuildRequires:  kfilemetadata5-devel
BuildRequires:  ki18n-devel >= 5.7.0
BuildRequires:  kiconthemes-devel >= 5.7.0
BuildRequires:  kinit-devel >= 5.7.0
BuildRequires:  kio-devel >= 5.7.0
BuildRequires:  knewstuff-devel >= 5.7.0
BuildRequires:  knotifications-devel >= 5.7.0
BuildRequires:  kparts-devel >= 5.7.0
BuildRequires:  ktexteditor-devel >= 5.7.0
BuildRequires:  kwindowsystem-devel >= 5.7.0
BuildRequires:  phonon4qt5-devel
BuildRequires:  pkgconfig
BuildRequires:  solid-devel >= 5.7.0
BuildRequires:  update-desktop-files
BuildRequires:  pkgconfig(Qt5Concurrent) >= 5.4.0
BuildRequires:  pkgconfig(Qt5Core) >= 5.4.0
BuildRequires:  pkgconfig(Qt5DBus) >= 5.4.0
BuildRequires:  pkgconfig(Qt5Gui) >= 5.4.0
BuildRequires:  pkgconfig(Qt5Widgets) >= 5.4.0
Requires:       baloo5-kioslaves
Requires:       dolphin-part = %{version}-%{release}
Recommends:     kio-extras5
Recommends:     konsole-part
Obsoletes:      dolphin5
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
This package contains the default file manager of KDE Workspaces.

%package part
Summary:        KDE File Manager
Group:          Productivity/File utilities
Obsoletes:      dolphin5-part
Recommends:     %{name}-part-lang
%requires_ge kio

%description part
This package contains the libraries used by Dolphin and Konqueror.

%package -n libdolphinvcs5
Summary:        KDE File Manager
Group:          Productivity/File utilities

%description -n libdolphinvcs5
This package contains the libraries used by Dolphin and Konqueror.

%package devel
Summary:        KDE File Manager
Group:          Productivity/File utilities
Requires:       libdolphinvcs5 = %{version}
Obsoletes:      dolphin5-devel < %{version}
Provides:       dolphin5-devel = %{version}

%description devel
This package contains the libraries used by Dolphin and Konqueror.

%if %{with lang}
%package -n %{name}-part-lang
Summary:        Translations for package %{name}
Group:          System/Localization
Requires:       %{name}-part = %{version}
Provides:       %{name}-lang = %{version}
Obsoletes:      %{name}-lang < %{version}

Provides:       %{name}-part-lang-all = %{version}
Supplements:    packageand(bundle-lang-other:%{name}-part)
BuildArch:      noarch

%description -n %{name}-part-lang

Provides translations for the "%{name}" package.
%endif

%prep
%setup -q -n dolphin-%{version}
%patch0 -p1
%patch1 -p1

%build
  %cmake_kf5 -d build
  %make_jobs

%install
  %kf5_makeinstall -C build
  %if %{with lang}
    %find_lang %{name} --with-man --all-name
    %kf5_find_htmldocs
  %endif

  install -D -m 0644 %{SOURCE1} %{buildroot}%{_kf5_applicationsdir}/org.kde.dolphinsu.desktop
  %suse_update_desktop_file org.kde.dolphin          System FileManager

  rm -rfv %{buildroot}%{_kf5_libdir}/libdolphinprivate.so
  find %{buildroot} -type f -name '*filenamesearch*' -exec rm -fv {} ';'

%post part -p /sbin/ldconfig
%postun part -p /sbin/ldconfig
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%post -n libdolphinvcs5 -p /sbin/ldconfig
%postun -n libdolphinvcs5 -p /sbin/ldconfig

%files
%defattr(-,root,root)
%doc COPYING* README
%{_kf5_libdir}/libkdeinit5_dolphin.so
%{_kf5_bindir}/dolphin
%{_kf5_applicationsdir}/org.kde.dolphin.desktop
%{_kf5_applicationsdir}/org.kde.dolphinsu.desktop
%dir %{_kf5_kxmlguidir}
%dir %{_kf5_kxmlguidir}/dolphin
%{_kf5_kxmlguidir}/dolphin/dolphinui.rc
%dir %{_kf5_appstreamdir}
%{_kf5_appstreamdir}/org.kde.dolphin.appdata.xml
%{_kf5_bindir}/servicemenuinstallation
%{_kf5_bindir}/servicemenudeinstallation
%dir %{_kf5_htmldir}/en
%dir %{_kf5_htmldir}
%doc %{_kf5_htmldir}/en/dolphin/
%{_datadir}/dbus-1/interfaces/org.freedesktop.FileManager1.xml
%{_datadir}/dbus-1/services/org.kde.dolphin.FileManager1.service

%files part
%defattr(-,root,root)
%doc COPYING* README
%{_kf5_libdir}/libdolphinprivate.so.*
%dir %{_kf5_plugindir}
%{_kf5_plugindir}/dolphinpart.so
%dir %{_kf5_kxmlguidir}
%dir %{_kf5_kxmlguidir}/dolphinpart
%{_kf5_kxmlguidir}/dolphinpart/dolphinpart.rc
%dir %{_kf5_servicesdir}
%{_kf5_servicesdir}/dolphinpart.desktop
%dir %{_kf5_servicetypesdir}
%{_kf5_servicetypesdir}/fileviewversioncontrolplugin.desktop
%{_kf5_plugindir}/kcm_dolphin*.so
%dir %{_kf5_configkcfgdir}
%{_kf5_configkcfgdir}/dolphin_*.kcfg
%{_kf5_servicesdir}/kcmdolphinviewmodes.desktop
%{_kf5_servicesdir}/kcmdolphinnavigation.desktop
%{_kf5_servicesdir}/kcmdolphinservices.desktop
%{_kf5_servicesdir}/kcmdolphingeneral.desktop
%config %{_kf5_configdir}/servicemenu.knsrc
#{_kf5_sharedir}/dolphinpart/

%files -n libdolphinvcs5
%defattr(-,root,root)
%doc COPYING* README
%{_kf5_libdir}/libdolphinvcs.so.*

%files devel
%defattr(-,root,root)
%doc COPYING* README
%{_kf5_libdir}/libdolphinvcs.so
%{_kf5_libdir}/cmake/DolphinVcs/
%{_kf5_prefix}/include/Dolphin/
%{_kf5_prefix}/include/dolphin_export.h
%{_includedir}/dolphinvcs_export.h

%if %{with lang}
%files part-lang -f %{name}.lang
%doc COPYING*
%endif

%changelog
openSUSE Build Service is sponsored by