File kcompletion.spec of Package kcompletion
#
# spec file for package kcompletion
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%bcond_without lang
%define lname libKF5Completion5
%define _tar_path 5.32
Name: kcompletion
Version: 5.32.0
Release: 0
%define kf5_version %{version}
BuildRequires: cmake >= 3.0
BuildRequires: extra-cmake-modules >= %{_tar_path}
BuildRequires: fdupes
BuildRequires: kconfig-devel >= %{_tar_path}
BuildRequires: kf5-filesystem
BuildRequires: kwidgetsaddons-devel >= %{_tar_path}
%if %{with lang}
BuildRequires: cmake(Qt5LinguistTools) >= 5.6.0
%endif
BuildRequires: cmake(Qt5Widgets) >= 5.6.0
Summary: Provides widgets with advanced completion support
License: LGPL-2.1+
Group: System/GUI/KDE
Url: http://www.kde.org
Source: http://download.kde.org/stable/frameworks/%{_tar_path}/%{name}-%{version}.tar.xz
Source1: baselibs.conf
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
KCompletion provides widgets with advanced completion support as well as a
lower-level completion class which can be used with your own widgets.
%package -n %lname
Summary: Provides widgets with advanced completion support
Group: System/GUI/KDE
%if %{with lang}
Recommends: %lname-lang = %{version}
%endif
%description -n %lname
KCompletion provides widgets with advanced completion support as well as a
lower-level completion class which can be used with your own widgets.
%package devel
Summary: Provides widgets with advanced completion support
Group: Development/Libraries/KDE
Requires: %lname = %{version}
Requires: extra-cmake-modules
Requires: cmake(Qt5Widgets) >= 5.6.0
%description devel
KCompletion provides widgets with advanced completion support as well as a
lower-level completion class which can be used with your own widgets. Development
files.
%lang_package -n %lname
%prep
%setup -q
%build
%cmake_kf5 -d build
%make_jobs
%install
%kf5_makeinstall -C build
%fdupes %{buildroot}
%if %{with lang}
%find_lang %{name}5 --with-qt --without-mo
%endif
%post -n %lname -p /sbin/ldconfig
%postun -n %lname -p /sbin/ldconfig
%if %{with lang}
%files -n %lname-lang -f %{name}5.lang
%endif
%files -n %lname
%defattr(-,root,root)
%doc COPYING* README*
%{_kf5_libdir}/libKF5Completion.so.*
%files devel
%defattr(-,root,root)
%{_kf5_libdir}/libKF5Completion.so
%{_kf5_libdir}/cmake/KF5Completion/
%dir %{_kf5_includedir}/*/
%{_kf5_includedir}/*/
%{_kf5_includedir}/*.h
%{_kf5_mkspecsdir}/qt_KCompletion.pri
%changelog