File plank.spec of Package plank
#
# spec file for package plank
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%define lname libplank1
%define _version 1.0
Name: plank
Version: 0.11.4
Release: 0
Summary: Elegant, simple, and clean dock
License: GPL-3.0+
Group: System/GUI/Other
Url: https://launchpad.net/plank
Source: https://launchpad.net/%{name}/%{_version}/%{version}/+download/%{name}-%{version}.tar.xz
Source2: https://launchpad.net/%{name}/%{_version}/%{version}/+download/%{name}-%{version}.tar.xz.asc
Source3: %{name}.keyring
BuildRequires: autoconf >= 2.65
BuildRequires: automake >= 1.11
BuildRequires: hicolor-icon-theme
BuildRequires: intltool
BuildRequires: libtool >= 2
BuildRequires: libxml2-tools
BuildRequires: pkg-config >= 0.21
BuildRequires: update-desktop-files
BuildRequires: vala >= 0.28.0
BuildRequires: pkgconfig(cairo)
BuildRequires: pkgconfig(dbusmenu-glib-0.4) >= 0.4
BuildRequires: pkgconfig(dbusmenu-gtk3-0.4) >= 0.4
BuildRequires: pkgconfig(gdk-pixbuf-2.0) >= 2.26.0
BuildRequires: pkgconfig(gdk-x11-3.0) >= 3.10.0
BuildRequires: pkgconfig(gee-0.8)
BuildRequires: pkgconfig(gio-2.0) >= 2.40
BuildRequires: pkgconfig(glib-2.0) >= 2.40
BuildRequires: pkgconfig(gobject-2.0) >= 2.34
BuildRequires: pkgconfig(gtk+-3.0) >= 3.10.0
BuildRequires: pkgconfig(libbamf3) >= 0.2.92
BuildRequires: pkgconfig(libwnck-3.0)
BuildRequires: pkgconfig(x11)
BuildRequires: pkgconfig(xfixes) >= 5.0
BuildRequires: pkgconfig(xi) >= 1.6.99.1
Requires: bamf-daemon >= 0.2.92
Recommends: %{name}-lang
%glib2_gsettings_schema_requires
%description
Plank is meant to be the simplest dock on the planet. The goal is
to provide just what a dock needs and absolutely nothing more.
It is, however, a library which can be extended to create other
dock programs with more advanced features.
%package -n %{lname}
Summary: Library for the Plank dock
Group: System/Libraries
%description -n %{lname}
Plank is meant to be the simplest dock on the planet. The goal is
to provide just what a dock needs and absolutely nothing more.
It is, however, a library which can be extended to create other
dock programs with more advanced features.
This package contains the plank library.
%package devel
Summary: Development files for the Plank dock
Group: Development/Libraries/C and C++
Requires: %{lname} = %{version}
%description devel
The libxnoise development package includes the header files, libraries,
configuration files and development tools necessary for compiling and
linking application which will use libplank.
%lang_package
%prep
%setup -q
%build
NOCONFIGURE=1 ./autogen.sh
%configure \
--disable-static \
--disable-apport
make %{?_smp_mflags}
%install
%make_install
%suse_update_desktop_file -r %{name} Utility DesktopUtility
find %{buildroot} -type f -name "*.la" -delete -print
%find_lang %{name}
%post
%icon_theme_cache_post
%desktop_database_post
%glib2_gsettings_schema_post
%postun
%desktop_database_postun
%icon_theme_cache_postun
%glib2_gsettings_schema_postun
%post -n %{lname} -p /sbin/ldconfig
%postun -n %{lname} -p /sbin/ldconfig
%files
%defattr(-,root,root)
%doc AUTHORS COPYING COPYRIGHT HACKING NEWS README
%{_bindir}/%{name}
%{_libdir}/%{name}/
%{_datadir}/%{name}/
%{_datadir}/applications/%{name}.desktop
%{_datadir}/icons/hicolor/*/apps/%{name}.*
%{_datadir}/glib-2.0/schemas/*%{name}.gschema.xml
%{_mandir}/man?/%{name}.?%{?ext_man}
%dir %{_datadir}/appdata
%{_datadir}/appdata/%{name}.appdata.xml
%files -n %{lname}
%defattr(-,root,root)
%{_libdir}/lib%{name}.so.*
%files lang -f %{name}.lang
%defattr(-,root,root)
%files devel
%defattr(-,root,root)
%{_libdir}/pkgconfig/%{name}.pc
%{_includedir}/%{name}/
%{_libdir}/libplank.so
%{_datadir}/vala/
%changelog