File LHAPDF.spec of Package LHAPDF
#
# spec file for package LHAPDF
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%define so_name libLHAPDF
%define execname lhapdf
Name: LHAPDF
Version: 6.1.6
Release: 0
Summary: A library for unified and easy to use interface to modern PDF sets
License: GPL-3.0
Group: Development/Libraries/C and C++
Url: http://lhapdf.hepforge.org
Source: http://www.hepforge.org/archive/lhapdf/%{name}-%{version}.tar.gz
BuildRequires: boost-devel >= 1.53.0
BuildRequires: doxygen
BuildRequires: gcc-c++
BuildRequires: pkg-config
BuildRequires: python-devel
BuildRequires: texlive-latex-bin
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
LHAPDF provides a unified and easy to use interface to modern PDF
sets. It is designed to work not only with individual PDF sets but
also with the more recent multiple "error" sets. It can be viewed as
the successor to PDFLIB, incorporating many of the older sets found in
the latter, including pion and photon PDFs. In LHAPDF the computer
code and input parameters/grids are separated thus allowing more easy
updating and no limit to the expansion possibilities. The code and
data sets can be downloaded together or inidivually as desired. From
version 4.1 onwards a configuration script facilitates the
installation of LHAPDF.
%package -n %{so_name}
Summary: A library for unified and easy to use interface to modern PDF sets
Group: Development/Libraries/C and C++
%description -n %{so_name}
LHAPDF provides a unified and easy to use interface to modern PDF
sets. It is designed to work not only with individual PDF sets but
also with the more recent multiple "error" sets. It can be viewed as
the successor to PDFLIB, incorporating many of the older sets found in
the latter, including pion and photon PDFs. In LHAPDF the computer
code and input parameters/grids are separated thus allowing more easy
updating and no limit to the expansion possibilities. The code and
data sets can be downloaded together or inidivually as desired. From
version 4.1 onwards a configuration script facilitates the
installation of LHAPDF.
This package provides the shared library for %{name}.
%package devel
Summary: A library for unified and easy to use interface to modern PDF sets
Group: Development/Libraries/C and C++
Requires: %{so_name} = %{version}
Requires: boost-devel
%description devel
LHAPDF provides a unified and easy to use interface to modern PDF
sets. It is designed to work not only with individual PDF sets but
also with the more recent multiple "error" sets. It can be viewed as
the successor to PDFLIB, incorporating many of the older sets found in
the latter, including pion and photon PDFs. In LHAPDF the computer
code and input parameters/grids are separated thus allowing more easy
updating and no limit to the expansion possibilities. The code and
data sets can be downloaded together or inidivually as desired. From
version 4.1 onwards a configuration script facilitates the
installation of LHAPDF.
This package provides the header and source files for development with
%{name}.
%package -n python-%{name}
Summary: A library for unified and easy to use interface to modern PDF sets
Group: Development/Libraries/C and C++
Requires: %{so_name} = %{version}
Requires: python
%description -n python-%{name}
LHAPDF provides a unified and easy to use interface to modern PDF
sets. It is designed to work not only with individual PDF sets but
also with the more recent multiple "error" sets. It can be viewed as
the successor to PDFLIB, incorporating many of the older sets found in
the latter, including pion and photon PDFs. In LHAPDF the computer
code and input parameters/grids are separated thus allowing more easy
updating and no limit to the expansion possibilities. The code and
data sets can be downloaded together or inidivually as desired. From
version 4.1 onwards a configuration script facilitates the
installation of LHAPDF.
This package provides the python wrapper for %{name}.
%prep
%setup -q
%build
%configure --disable-static --docdir=%{_docdir}/%{name}/
make %{?_smp_mflags}
%install
%make_install
find %{buildroot}%{_libdir}/ -name "*.la" -delete
%post -n %{so_name}
/sbin/ldconfig
%postun -n %{so_name}
/sbin/ldconfig
%files -n %{so_name}
%defattr(-, root, root)
%{_libdir}/*.so
%files devel
%defattr(-, root, root)
%doc AUTHORS ChangeLog COPYING
%{_bindir}/%{execname}
%{_bindir}/%{execname}-*
%{_datadir}/%{name}/
%{_includedir}/%{name}
%{_libdir}/pkgconfig/%{execname}.pc
%files -n python-%{name}
%defattr(-, root, root)
%{python_sitearch}/%{name}-*.egg-info
%{python_sitearch}/%{execname}.so
%changelog