File python3-wheel.spec of Package python3-wheel
#
# spec file for package python3-wheel
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: python3-wheel
Version: 0.29.0
Release: 0
Summary: A built-package format for Python
License: MIT
Group: Development/Languages/Python
Url: https://bitbucket.org/pypa/wheel
Source: https://files.pythonhosted.org/packages/source/w/wheel/wheel-%{version}.tar.gz
BuildRequires: python3-devel
BuildRequires: python3-setuptools
# Test requirements:
BuildRequires: python3-jsonschema
BuildRequires: python3-pytest
BuildRequires: python3-pytest-cov
Recommends: python3-ed25519ll
Recommends: python3-dirspec
Recommends: python3-keyring
Requires(post): update-alternatives
Requires(postun): update-alternatives
BuildArch: noarch
%description
A built-package format for Python.
A wheel is a ZIP-format archive with a specially formatted filename
and the .whl extension. It is designed to contain all the files for a
PEP 376 compatible install in a way that is very close to the on-disk
format. Many packages will be properly installed with only the "Unpack"
step (simply extracting the file onto sys.path), and the unpacked archive
preserves enough information to "Spread" (copy data and scripts to their
final locations) at any later time.
The wheel project provides a bdist_wheel command for setuptools
(requires distribute >= 0.6.34). Wheel files can be
installed with a newer pip from https://github.com/pypa/pip
or with wheel's own command line utility.
The wheel documentation is at http://wheel.rtfd.org/. The
file format is documented in PEP 427
(http://www.python.org/dev/peps/pep-0427/).
The reference implementation is at http://bitbucket.org/dholth/wheel/
%prep
%setup -q -n wheel-%{version}
%build
python3 setup.py build
%install
python3 setup.py install --prefix=%{_prefix} --root=%{buildroot}
mkdir -p %{buildroot}%{_sysconfdir}/alternatives
for b in wheel ; do
mv %{buildroot}%{_bindir}/$b %{buildroot}%{_bindir}/$b-%{py3_ver}
touch %{buildroot}%{_sysconfdir}/alternatives/$b
ln -sf %{_sysconfdir}/alternatives/$b %{buildroot}/%{_bindir}/$b
done
%check
python3 setup.py test
%post
update-alternatives --install %{_bindir}/wheel wheel %{_bindir}/wheel-%{py3_ver} 30
%postun
if [ $1 -eq 0 ] ; then
update-alternatives --remove wheel %{_bindir}/wheel-%{py3_ver}
fi
%files
%defattr(-,root,root,-)
%doc CHANGES.txt README.txt LICENSE.txt
%{_bindir}/wheel
%{_bindir}/wheel-%{py3_ver}
%ghost %{_sysconfdir}/alternatives/wheel
%{python3_sitelib}/wheel-%{version}-py%{py3_ver}.egg-info
%{python3_sitelib}/wheel/
%changelog