File mingw64-breeze5-icons.spec of Package mingw64-breeze5-icons
#
# spec file for package mingw64-breeze5-icons
#
# Copyright (c) 2019 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define _tar_path 5.103
# Full KF5 version (e.g. 5.33.0)
%{!?_mingw64_kf5_version: %global _mingw64_kf5_version %{version}}
# Last major and minor KF5 version (e.g. 5.33)
%{!?_mingw64_kf5_bugfix_version: %define _mingw64_kf5_bugfix_version %(echo %{_mingw64_kf5_version} | awk -F. '{print $1"."$2}')}
# Only needed for the package signature condition
%bcond_without lang
%define _name breeze5-icons
Name: mingw64-%{_name}
Version: 5.103.0
Release: 0
Summary: Breeze icon theme
License: LGPL-3.0-only
Group: System/GUI/KDE
URL: https://www.kde.org
Source: https://download.kde.org/stable/frameworks/%{_tar_path}/breeze-icons-%{version}.tar.xz
%if %{with lang}
Source1: https://download.kde.org/stable/frameworks/%{_tar_path}/breeze-icons-%{version}.tar.xz.sig
Source2: frameworks.keyring
%endif
# PATCH-FIX-OPENSUSE oxygen.diff -- inherit from oxygen
Patch0: oxygen.diff
# PATCH-FIX_UPSTREAM
Patch1: 0001-Moved-qrcalias-to-subdir-to-use-it-as-separate-cmake.patch
BuildRequires: gcc-c++
BuildRequires: cmake(Qt5Core)
BuildRequires: mingw64-cross-cmake
BuildRequires: mingw64-cross-gcc-c++
BuildRequires: mingw64-extra-cmake-modules >= %{_mingw64_kf5_bugfix_version}
BuildRequires: mingw64-hicolor-icon-theme
BuildRequires: mingw64-libxml2-tools
BuildRequires: mingw64(cmake:Qt5Core) >= 5.11.0
BuildRequires: mingw64(cmake:Qt5Test) >= 5.11.0
Requires: mingw64-oxygen5-icon-theme
BuildArch: noarch
%_mingw64_package_header_debug
%description
Breeze-icons is a freedesktop.org compatible icon theme.
%_mingw64_debug_package
%prep
%setup -q -n breeze-icons-%{version}
%autopatch -p1
%build
# build native qrcAlias
mkdir tmpbuild
cd tmpbuild
cmake ../qrcalias
make
bindir=$PWD
cd ..
%_mingw64_cmake_kf5 -d build -- -DBINARY_ICONS_RESOURCE=ON -DQRCALIAS_EXECUTABLE=$bindir/qrcAlias
%_mingw64_cmake_build
%install
%_mingw64_kf5_makeinstall -C build
%if 0
# yast2-theme uses these, but it got renamed in 5.55.0
ln -s yast-software-group.svg %{buildroot}%{_mingw64_kf5_iconsdir}/breeze/preferences/32/yast-software.svg
ln -s yast-software-group.svg %{buildroot}%{_mingw64_kf5_iconsdir}/breeze-dark/preferences/32/yast-software.svg
%endif
%_mingw64_icon_theme_cache_create_ghost breeze
%_mingw64_icon_theme_cache_create_ghost breeze-dark
%post
%_mingw64_icon_theme_cache_post breeze
%_mingw64_icon_theme_cache_post breeze-dark
%files
%license COPYING*
%ghost %{_mingw64_kf5_iconsdir}/breeze/icon-theme.cache
%ghost %{_mingw64_kf5_iconsdir}/breeze-dark/icon-theme.cache
%{_mingw64_kf5_iconsdir}/breeze/
%{_mingw64_kf5_iconsdir}/breeze-dark/
%changelog