LogoopenSUSE Build Service > Request 173550
Sign Up | Log In

Request 173550 (superseded)

- Fix build on SLES 11 (no firebird) and openSUSE <= 12.1 (no separate
  libfbclient2-devel pkg).

- Conflict with php53 packages so zypper doesn't suggest installing a
  mix of php53-* (from SLES 11) and php5-* (these 5.4 packages).
  + Unless the repo priority is adjusted higher than the SLES repos,
    'zypper in php5' will install this php but php53-ctype, etc.,
    and installing an extension package directly may fail due to conflicts.

    With this conflict setting in place, zypper behaves properly without
    having to set priority.

Submit package home:adaugherity:branches:server:php / php5 to package server:php / php5

home:adaugherity:branches:server:php

There's nothing to be done right now

Request History

Andrew Daugherity adaugherity created request almost 3 years ago
- Fix build on SLES 11 (no firebird) and openSUSE <= 12.1 (no separate
  libfbclient2-devel pkg).

- Conflict with php53 packages so zypper doesn't suggest installing a
  mix of php53-* (from SLES 11) and php5-* (these 5.4 packages).
  + Unless the repo priority is adjusted higher than the SLES repos,
    'zypper in php5' will install this php but php53-ctype, etc.,
    and installing an extension package directly may fail due to conflicts.

    With this conflict setting in place, zypper behaves properly without
    having to set priority.
Andrew Daugherity adaugherity Request got superseded by request 175318 almost 3 years ago
[Request originally submitted to server:php/php5, with no action after 2+
weeks; I just discovered that development seems to happening here rather than
there, so I'm submitting my updated request here.]

- Conflict with php53 packages so zypper doesn't suggest installing a
  mix of php53-* (from SLES 11) and php5-* (these 5.4 packages).

- Fix build on SLES 11 (no firebird) and openSUSE <= 12.1 (no separate
  libfbclient2-devel pkg).

Comments for request 173550 (0)