Edit Package wine

An MS Windows emulator

An MS Windows emulator, consisting of both runtime and also source
compatibility functions. You can run your MS executables with it, and
you can write your Windows programs under Linux and link against the
WINE libraries.

It is not necessary to have a Windows installation to run WINE.

Please have a look at /usr/share/doc/packages/wine/README.SuSE. There
is more documentation available in that directory. Read 'man wine' for
further information.

You can invoke wine by entering: 'wine program.exe' wine can be
configured by running 'winecfg'.

Refresh
Refresh
Source Files (show merged sources derived from linked package)
Filename Size Changed
baselibs.conf 0000000401 401 Bytes over 9 years
project.diff 0000000487 487 Bytes about 8 years
susepatches.patch 0000000666 666 Bytes over 9 years
ubuntuwine.tar.bz2 0000026725 26.1 KB about 8 years
wine.changes 0000213601 209 KB 14 days
wine.dsc 0000001243 1.21 KB about 6 years
wine.spec 0000020298 19.8 KB 13 days
wisotool 0000317786 310 KB almost 11 years
Comments 9

magist3r sergei's avatar

magist3r wrote over 3 years ago

Hi. Looks like 32bit vulkan library was added to Leap 42.3: https://lists.opensuse.org/opensuse-updates/2018-04/msg00018.html. Can you build wine with vulkan for 32bit too?


Rafał Miłecki's avatar

zajec wrote 14 days ago

Hi, I noticed that:
1. openSUSE 15.2 comes with wine 5.0 without vkd3d dependency
2. openSUSE 15.3 comes with wine 6.0 without vkd3d dependency
3. openSUSE Tumbleweed comes with wine 6.19 that depends on libvkd3d1

I tested wine from Emulators:Wine with:
1. openSUSE_Leap_15.2
2. openSUSE_Leap_15.2_Update
3. openSUSE_Leap_15.3
and none of above depends on vkd3d. I guess it means it doesn't support vkd3d (aka Direct3D 12). Whenever I tried to run Diablo II: Resurrected I get "Failed to initialize graphics device." error.

Is that possible to compile wine for 15.2 and 15.3 in Emulators:Wine with vkd3d (aka Direct3D 12) support, please?


Эникей Админ's avatar

linux4humans wrote 13 days ago

Hello zajec. I enable vkd3d for openSUSE 15 just now. Previously I'd enabled vkd3d only for Tumbleweed because there wasn't vkd3d package in 15.0 that was actual version in that moment. Now 15.1-15.3 releases available but I didn't edit the SPEC. Thank you for reply.

Edit: I see that vkd3d is still unavailable in openSUSE 15.1 32-bit. I will think about that for making a rule for enable it only for >= 15.2.

Edit2: It's also unavailable in 15.3 32-bit. But it's available in 15.2 for all architectures. It's strange. I'll ask Marcus about that.


Rafał Miłecki's avatar

zajec wrote 13 days ago

Thank you so much for looking into this!

I've just installed wine-6.19-lp152.1377.1.x86_64 but it doesn't pull (depend on) libvkd3d.

I checked build log I found: https://build.opensuse.org/build/Emulators:Wine/openSUSE_Leap_15.2/x86_64/wine/_log and it contains:

[  148s] checking for -lvkd3d... not found
[  148s] checking for -lvkd3d-shader... not found
(...)
[  169s] configure: vkd3d 64-bit development files not found (or too old), Direct3D 12 won't be supported.

I tried to ./configure wine-6.19 locally on my openSUSE 15.2 and I have the same problem as above.


Rafał Miłecki's avatar

zajec wrote 13 days ago

I've found vkd3d-devel-1.2-lp152.36.1 in the graphics repository, installed it and tried ./configure again. It worked:

checking for -lvkd3d... libvkd3d.so.1
checking for -lvkd3d-shader... libvkd3d-shader.so.1

It seems that wine-6.19 can't work with vkd3d 1.1 from the openSUSE 15.2 main repository (it's probably too old?) :(

Is there any solution for that? Both 15.2 and 15.3 come with 1.1. Is that a good / acceptable idea to make Emulators:Wine provide 1.2 and make its wine depend on it?


Rafał Miłecki's avatar

zajec wrote 13 days ago

https://source.winehq.org/git/wine.git/commitdiff/681105fd482cb790568576c1d0a360288904ec82 ("d3d12: Implement D3D12SerializeVersionedRootSignature() on top of vkd3d_serialize_versioned_root_signature().")

Wine 6.1 and all newer require vkd3d 1.2+.


Marcus Meissner's avatar

msmeissn wrote 13 days ago

I linked the factory vkd3d into Emulators:Wine, which should fix it.

There was no i586 version in 15.3.


Rafał Miłecki's avatar

zajec wrote 13 days ago

https://build.opensuse.org/build/Emulators:Wine/openSUSE_Leap_15.2_Update/x86_64/wine/_log
looks good!

[  102s] checking for -lvkd3d... libvkd3d.so.1
[  102s] checking for -lvkd3d-shader... libvkd3d-shader.so.1

Package installation pulls libvkd3d too!

The following 2 NEW packages are going to be installed:
  libvkd3d-shader1 libvkd3d1

The following package is going to be upgraded:
  wine

Rafał Miłecki's avatar

zajec wrote 13 days ago

Seems to work for 32bit version as well. Thank you linux4humans & msmeissn.

The following 3 NEW packages are going to be installed:
  libvkd3d-shader1-32bit libvkd3d1-32bit wine-32bit

Sadly Diablo II: Resurrected still doesn't start:

Failed to initialize graphics device. Please ensure your PC meets the minimum system requirements and your drivers are up to date.

but I can't blame openSUSE's wine for that. I'll keep looking for solution to that somewhere else.

openSUSE Build Service is sponsored by