Graph Theory IDE

https://edu.kde.org

Rocs is a Graph Theory IDE for helping professors to show the results
of a graph algorithm and also helping students to do the algorithms.

Rocs has a scripting module, done in Qt Script, which interacts with
the drawn graph and every change in the graph with the script is
reflected on the drawn one.

Refresh
Refresh
Source Files
Filename Size Changed
_service 0000000508 508 Bytes 8 months
rocs.changes 0000080565 78.7 KB 2 months
rocs.spec 0000004558 4.45 KB 2 months
Comments for rocs 1

Fabian Vogt's avatar

favogt wrote almost 2 years ago

This package has installation issues and may not be installable from the KDE_Unstable_Frameworks_openSUSE_Factory repository:

can't install librocsgraphtheory0-19.03.60git.20190106T114236~4cacc56d-39.10.i586:
  package librocsgraphtheory0-19.03.60git.20190106T114236~4cacc56d-39.10.i586 requires libKF5Declarative.so.5, but none of the providers can be installed
  nothing provides libQt5Core5 = 5.12.1 needed by libKF5Declarative5-5.56.0git.20190313T155315~72f438f-30.1.i586
    (we have libQt5Core5-5.12.2-1.1.i586)

can't install librocsgraphtheory0-19.03.60git.20190106T114236~4cacc56d-39.10.x86_64:
  package librocsgraphtheory0-19.03.60git.20190106T114236~4cacc56d-39.10.x86_64 requires libKF5Declarative.so.5()(64bit), but none of the providers can be installed
  nothing provides libQt5Core5 = 5.12.1 needed by libKF5Declarative5-5.56.0git.20190313T155315~72f438f-30.1.x86_64
    (we have libQt5Core5-5.12.2-1.1.x86_64)

can't install rocs-19.03.60git.20190106T114236~4cacc56d-39.10.i586:
  package rocs-19.03.60git.20190106T114236~4cacc56d-39.10.i586 requires librocsgraphtheory.so.0, but none of the providers can be installed
  package librocsgraphtheory0-19.03.60git.20190106T114236~4cacc56d-39.10.i586 requires libKF5Declarative.so.5, but none of the providers can be installed
  nothing provides libQt5Core5 = 5.12.1 needed by libKF5Declarative5-5.56.0git.20190313T155315~72f438f-30.1.i586
    (we have libQt5Core5-5.12.2-1.1.i586)

can't install rocs-19.03.60git.20190106T114236~4cacc56d-39.10.x86_64:
  package rocs-19.03.60git.20190106T114236~4cacc56d-39.10.x86_64 requires librocsgraphtheory.so.0()(64bit), but none of the providers can be installed
  package librocsgraphtheory0-19.03.60git.20190106T114236~4cacc56d-39.10.x86_64 requires libKF5Declarative.so.5()(64bit), but none of the providers can be installed
  nothing provides libQt5Core5 = 5.12.1 needed by libKF5Declarative5-5.56.0git.20190313T155315~72f438f-30.1.x86_64
    (we have libQt5Core5-5.12.2-1.1.x86_64)

can't install rocs-devel-19.03.60git.20190106T114236~4cacc56d-39.10.i586:
  package rocs-devel-19.03.60git.20190106T114236~4cacc56d-39.10.i586 requires librocsgraphtheory0 = 19.03.60git.20190106T114236~4cacc56d, but none of the providers can be installed
  package librocsgraphtheory0-19.03.60git.20190106T114236~4cacc56d-39.10.i586 requires libKF5Declarative.so.5, but none of the providers can be installed
  nothing provides libQt5Core5 = 5.12.1 needed by libKF5Declarative5-5.56.0git.20190313T155315~72f438f-30.1.i586
    (we have libQt5Core5-5.12.2-1.1.i586)

can't install rocs-devel-19.03.60git.20190106T114236~4cacc56d-39.10.x86_64:
  package rocs-devel-19.03.60git.20190106T114236~4cacc56d-39.10.x86_64 requires librocsgraphtheory0 = 19.03.60git.20190106T114236~4cacc56d, but none of the providers can be installed
  package librocsgraphtheory0-19.03.60git.20190106T114236~4cacc56d-39.10.x86_64 requires libKF5Declarative.so.5()(64bit), but none of the providers can be installed
  nothing provides libQt5Core5 = 5.12.1 needed by libKF5Declarative5-5.56.0git.20190313T155315~72f438f-30.1.x86_64
    (we have libQt5Core5-5.12.2-1.1.x86_64)
openSUSE Build Service is sponsored by