LogoopenSUSE Build Service > Projects
Sign Up | Log In

armadillo
http://arma.sourceforge.net/

Armadillo is a C++ linear algebra library (matrix maths) aiming towards a good balance between speed and ease of use. Integer, floating point and complex numbers are supported, as well as a subset of trigonometric and statistics functions.  Various matrix decompositions are provided through optional integration with LAPACK and ATLAS libraries. A delayed evaluation approach is employed (during compile time) to combine several operations into one and reduce (or eliminate)   the need for temporaries. This is accomplished through recursive templates and template meta-programming. This library is useful if C++ has been decided as the language of choice (due to speed and/or integration capabilities), rather than another language like Matlab or Octave.


  

Source Files (show merged sources derived from linked package)

Filename Size Changed Actions
armadillo-8.500.1.tar.xz 4.55 MB about 1 month ago
armadillo.changes 47.2 KB about 1 month ago Download File
armadillo.spec 4.44 KB about 1 month ago Download File
baselibs.conf 115 Bytes 10 months ago Download File

Comments for devel:libraries:c_c++ (1)

Repo Checker repo-checker wrote 4 months ago

The version of this package in openSUSE:Leap:15.0 has installation issues and may not be installable:

can't install armadillo-devel-32bit-8.300.3-lp150.1.2.x86_64:
  package armadillo-devel-8.300.3-lp150.1.2.x86_64 requires arpack-ng-devel, but none of the providers can be installed
  package arpack-ng-devel-3.5.0-lp150.1.3.x86_64 requires gcc-fortran, but none of the providers can be installed
  package armadillo-devel-32bit-8.300.3-lp150.1.2.x86_64 requires armadillo-devel = 8.300.3, but none of the providers can be installed
  package gcc-fortran-7-lp150.1.27.x86_64 requires gcc7-fortran, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-fortran-7.3.0+r257042-lp150.1.3.x86_64

can't install armadillo-devel-8.300.3-lp150.1.2.x86_64:
  package arpack-ng-devel-3.5.0-lp150.1.3.x86_64 requires gcc-fortran, but none of the providers can be installed
  package armadillo-devel-8.300.3-lp150.1.2.x86_64 requires arpack-ng-devel, but none of the providers can be installed
  package gcc-fortran-7-lp150.1.27.x86_64 requires gcc7-fortran, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-fortran-7.3.0+r257042-lp150.1.3.x86_64