Edit Package deluge

BitTorrent Client

Deluge is a Free Software, cross-platform BitTorrent client on Python and Gtk2 with multiple user interfaces in client/server model.

Refresh
Refresh
Source Files
Filename Size Changed
deluge-1.3.15.tar.xz 0001467368 1.4 MB about 5 years
deluge-suse-geoip-location.patch 0000000377 377 Bytes about 6 years
deluge-update_7z_binary.patch 0000000961 961 Bytes almost 7 years
deluge.changes 0000006812 6.65 KB about 5 years
deluge.spec 0000003011 2.94 KB about 5 years
Comments 1

Silviu Marin-Caea's avatar

silviumc wrote over 1 year ago

Version 1.3.15 doesn't support libtorrent 1.2 and that's the only libtorrent version available in 15.2. So when you install deluge 1.3.15 it installs libtorrent-rasterbar10-1.2.4 as a dependency. The error message when you try to start deluged is [ERROR ] 01:29:49 main:248 'module' object has no attribute 'session_settings' Traceback (most recent call last): File "/usr/lib/python2.7/site-packages/deluge/main.py", line 241, in start_daemon Daemon(options, args) File "/usr/lib/python2.7/site-packages/deluge/core/daemon.py", line 147, in init read_only_config_keys=read_only_config_keys) File "/usr/lib/python2.7/site-packages/deluge/core/core.py", line 106, in init self.settings = lt.session_settings() AttributeError: 'module' object has no attribute 'session_settings'

https://forum.deluge-torrent.org/viewtopic.php?t=55535

Deluge version 2.0.3 supports libtorrent 1.2

openSUSE Build Service is sponsored by