LogoopenSUSE Build Service > Projects > home:cornelisbb:appmenu > Overview
Sign Up | Log In

Additional appmenu support

Additional packages for appmenu (to be used together with KDE 4)

Appmenu support works with Qt4 and Qt5 (only 13.2) and gtk2, but not for gtk3, firefox, thunderbird, or libreoffice.

For GTK2 apps to work add the following line to ~/.profile:

export UBUNTU_MENUPROXY="libappmenu.so"

For Qt5 the following line needs to be added:

export QT_QPA_PLATFORMTHEME="appmenu-qt5"

If this platformtheme is used, Qt5 apps will follow KDE 4 theming (found in ~/.kde4/share/config/kdeglobals), *not* the Plasma 5 one (in ~/.config/kdeglobals). Of course for Qt4 the right setting needs to be used in KDE 4's systemsettings.

As far as I know this is not supported on Plasma 5

I added a rough patch to rip out the gtk-theme so that kde theme is used. Somehow gtk-theme got in the way.

TODO: native file-picker. Now Qt5's is always used.

Also build  here are Firefox and Thunderbird with globalmenu patches from ubuntu. They work under kde, but are not perfect.

Have a lot of fun!

Comments for home:cornelisbb:appmenu (0)