Qt5 for SLE 11 and 12

Hello! This is Qt 5.6 for SLE 11 and 12!

It was built without xcb-xlib package, so we needed to rebuild some packages
without them. We ran some analog of revdep-rebuild in our /usr/lib, and we found
that xorg-x11-libX11 is the only one dependency of xcb-xlib.so library. Just install
libX11-* (without -devel) and libxcb-* (without -devel)

For QMMP package you need enable Packman repository.

Name Changed
Comments 2

alex Nsky's avatar

ansky wrote over 1 year ago

Здравствуйте. На работе есть кластер на SLES 11.1. Мне нужно поставить CODEBLOCKS FORTRAN(CB) IDE и DOUBLE COMMANDER(DC). CB- необходим для дела, DC- желателен. Для CB есть dev репозиторий SLES 11.1 на opensuse, для DC нужен rpm для qt5. Вопрос- насколько это безопасно для системы. Я не линуксоид - на персоналке поставил CENTOS - там проблем не возникло. Доставил rpm вручную. Но SLESа опасаюсь - древний. С уважением, Александр


Эникей Админ's avatar

linux4humans wrote over 1 year ago

Ты можешь установить старую версию DC на Qt4. Поищи на зеркале Яндекса, там не удаляют репозитории SLE 11 SP4. Безопасность системы не должна быть затронута. P.S. Загляни в соседний репозиторий qt_5.6_lts или qt_5.9. Если представляет интерес, я обновлю до актуальных версий. Добавляешь репозиторий в YAST, заходишь в yast-qt (yast-gtk лучше удалить - он какой-то урезанны) и жмёшь "перевести системные пакеты на версии из этого репозитория". Тебе установится новая версия libxcb, необходимая для Qt 5. Дальше устанавливаешь сам Qt 5.

openSUSE Build Service is sponsored by