File banshee.spec of Package banshee

#
# spec file for package banshee (Version 0.13.2)
#
# Copyright (c) 2007 SUSE LINUX Products GmbH, Nuernberg, Germany.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild

Name:           banshee
%define         HELIX_BANSHEE 0
# WARNING: If you are editing helix-banshee.spec, STOP. Always edit 
# banshee.spec and then run helix-banshee-fixup.sh which will create
# helix-banshee.spec based upon banshee.spec.
%if %HELIX_BANSHEE == 1
ExclusiveArch: %ix86 x86_64
%else
ExcludeArch: s390 s390x
%endif
%define src_name banshee
%define prefix /usr
%if %suse_version < 1030
%define sysconfdirprivate etc/opt/gnome
%define gstreamerprefix /opt/gnome
%define gstreamerprefixprivate opt/gnome
%else
%define sysconfdirprivate etc
%define gstreamerprefix /usr
%define gstreamerprefixprivate usr
%endif
%define sysconfdir /%{sysconfdirprivate}
%define gconf_config_source %{gstreamerprefixprivate}/bin/gconftool-2 --get-default-source
%define gconf_schema_install %{gstreamerprefixprivate}/bin/gconftool-2 --makefile-install-rule %{sysconfdirprivate}/gconf/schemas
%define gst_branch 0.10
%define dbus_min_version 0.60-26
%define hds_min_version 0.4.0
%define podsleuth_min_version 0.6.1
%define ipodsharp_min_version 0.8.0
%define hxbc_version 0.11.5
BuildRequires:  dbus-1-devel gcc-c++ gconf-sharp2 gdk-pixbuf-devel glade-sharp2 gnome-desktop-devel gnome-sharp2 gnome-vfs2 gstreamer010-plugins-base-devel gstreamer010-plugins-good gtk-sharp2-gapi intltool ipod-sharp >= 0.8.0 libglade2-devel libidl-devel libmusicbrainz-devel libwnck-devel mono-basic mono-data-sqlite mono-devel monodoc-core mono-zeroconf nautilus-cd-burner-devel perl-XML-Parser sqlite-devel update-desktop-files ndesk-dbus ndesk-dbus-glib
%if %suse_version <= 1020
BuildRequires: mono-zeroconf-provider-mDNSResponder
%endif
%if %HELIX_BANSHEE == 1
%ifarch %ix86 x86_64
BuildRequires:  RealPlayer helix-dbus-server >= %{hds_min_version}
%endif
%endif
License:        X11/MIT
Group:          Productivity/Multimedia/Sound/Players
Autoreqprov:    on
PreReq:         filesystem gconf2
Requires:       mono-core
Version:        0.13.2
Release:        20
Source0:        banshee-%{version}.tar.bz2
%if %HELIX_BANSHEE == 1
Source1:        gstreamer-xing-0.10.2.tar.gz
Source2:        helix-banshee-client-%{hxbc_version}.tar.bz2
%endif
%if ! 0%{?opensuse_bs}
Source3:        helix-banshee-fixup.sh
%endif
URL:            http://banshee-project.org
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Summary:        A Music Player
BuildRequires:  ipod-sharp >= %{ipodsharp_min_version}
Requires:       podsleuth >= %{podsleuth_min_version} libmusicbrainz
Requires:       gstreamer010 gstreamer010-plugins-base gstreamer010-plugins-good gstreamer010-plugins-base-oil
%if %HELIX_BANSHEE == 1
Requires:       helix-banshee-engine = %{version}
%else
Requires:       banshee-engine = %{version}
%endif
Requires:       dbus-1-glib >= %{dbus_min_version}
Requires:       dbus-1-x11 >= %{dbus_min_version}
Provides:       banshee-player
%if %HELIX_BANSHEE == 1
Conflicts:      banshee
Recommends:     helix-banshee-engine-gst helix-banshee-plugins-default helix-banshee-plugins-extra helix-banshee-engine-helix
%else
Conflicts:      helix-banshee
Recommends:     banshee-engine-gst banshee-plugins-default banshee-plugins-extra
%endif
%if %suse_version >= 1030

%gconf_schemas_prereq
%endif

%description
Banshee is a music management and playback application. It supports
both CD importing and writing, and is compatible with many digital
audio players.



Authors:
--------
    Aaron Bockover <aaron@aaronbock.net>

%package devel
Summary:        A Music Player
Group:          Productivity/Multimedia/Sound/Players
Autoreqprov:    on
Requires:       %{name} = %{version}
Requires:       gtk2-devel nautilus-cd-burner-devel hal-devel gnome-vfs2-devel 
Requires:       gstreamer010-devel gstreamer010-plugins-base-devel
Requires:       gtk-sharp2 gconf-sharp2

%description devel
Banshee is a music management and playback application. It supports
both CD importing and writing, and is compatible with many digital
audio players.



Authors:
--------
    Aaron Bockover <aaron@aaronbock.net>

%package engine-gst
Summary:        GStreamer playback engine for Banshee
Group:          Productivity/Multimedia/Sound/Players
Autoreqprov:    on
Requires:       %{name} = %{version}
Provides:       %{name}-engine = %{version}

%description engine-gst
Banshee is a music management and playback application. It supports
both CD importing and writing, and is compatible with many digital
audio players.



Authors:
--------
    Aaron Bockover <aaron@aaronbock.net>

%if %HELIX_BANSHEE == 1
%package engine-helix
Summary:        The Helix engine backend
Group:          Productivity/Multimedia/Sound/Players
Autoreqprov:    on
Requires:       %{name} = %{version}
Requires:       RealPlayer
Requires:       helix-dbus-server >= %{hds_min_version}
Provides:       %{name}-engine = %{version}

%description engine-helix
banshee is an audio player based on the GStreamer media library and is
developed on the open source Mono .NET Platform, written in C#.



Authors:
--------
    Aaron Bockover <aaron@aaronbock.net>

%endif
%package plugins-default
Summary:        Default Banshee plugins
Group:          Productivity/Multimedia/Sound/Players
Autoreqprov:    on
Requires:       %{name} = %{version}
%if %suse_version >= 1030

%gconf_schemas_prereq
%endif

%description plugins-default
A default set of plugins for Banshee including AudioScrobbler support,
notification area icon, multimedia keys support, and more.



Authors:
--------
    Aaron Bockover <aaron@aaronbock.net>

%package plugins-extra
Summary:        Extra Banshee plugins
Group:          Productivity/Multimedia/Sound/Players
Autoreqprov:    on
Requires:       %{name} = %{version}
%if %suse_version >= 1030

%gconf_schemas_prereq
%endif

%description plugins-extra
Banshee plugins for Podcasting, MiniMode, and automatic music
recommendations



Authors:
--------
    Aaron Bockover <aaron@aaronbock.net>

%package plugins-DAAP
Summary:        Banshee Plugin for DAAP
Group:          Productivity/Multimedia/Sound/Players
Autoreqprov:    on
Requires:       %{name} = %{version}
%if %suse_version >= 1030

%gconf_schemas_prereq
%endif

%description plugins-DAAP
Digital Audio Access Protocol plugin for Banshee.



Authors:
--------
    Aaron Bockover <aaron@aaronbock.net>

%prep
%if %HELIX_BANSHEE == 1
%setup -q -n%{src_name}-%{version} -b1 -b2
%else
%setup -q 
%endif

%build
%if %suse_version > 1000
export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -fstack-protector"
%endif
%ifarch x86_64
# find helix-dbus-server (32bit)
export PKG_CONFIG_PATH="$PKG_CONFIG_PATH:/usr/lib/pkgconfig"
%endif
export CFLAGS="$RPM_OPT_FLAGS"
./configure \
	--prefix=%{prefix} \
	--libdir=%{prefix}/%_lib \
	--sysconfdir=%{sysconfdir} \
	--disable-docs \
	--enable-external-ndesk-dbus
make
%if %HELIX_BANSHEE == 1
cd ../helix-banshee-client-%{hxbc_version}
export BANSHEE_BUILD_ROOT="$RPM_BUILD_DIR/%{src_name}-%{version}"
PKG_CONFIG_PATH="$PKG_CONFIG_PATH:$BANSHEE_BUILD_ROOT/build" \
BANSHEE_CFLAGS="" \
BANSHEE_LIBS="-r:$BANSHEE_BUILD_ROOT/src/Core/Banshee.Base/Banshee.Base.dll -r:$BANSHEE_BUILD_ROOT/src/Core/Banshee.Widgets/Banshee.Widgets.dll -r:$BANSHEE_BUILD_ROOT/ext/taglib-sharp/TagLib.dll -r:$BANSHEE_BUILD_ROOT/ext/hal-sharp/Hal.dll -r:$BANSHEE_BUILD_ROOT/src/Extras/MusicBrainz/MusicBrainz.dll -r:$BANSHEE_BUILD_ROOT/ext/dbus-sharp/NDesk.DBus.dll -r:$BANSHEE_BUILD_ROOT/ext/dbus-sharp/NDesk.DBus.GLib.dll -r:Mono.Posix -pkg:gtk-sharp-2.0 -pkg:gnome-sharp-2.0" \
./configure \
	--prefix=%{prefix} \
	--libdir=%{prefix}/%_lib \
	--sysconfdir=%{sysconfdir}
make
unset BANSHEE_BUILD_ROOT
cd ../gstreamer-xing-0.10.2
CFLAGS="$RPM_OPT_FLAGS" \
CXXFLAGS="$RPM_OPT_FLAGS" \
./configure
make
%endif

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make install DESTDIR=$RPM_BUILD_ROOT
# the magic gconf macros don't seem to work with schema files named
# banshee-whatever when the package is really named helix-banshee, so we
# perform this unutterable incantation.  
%if %HELIX_BANSHEE == 1
    %if %suse_version >= 1030
        pushd $RPM_BUILD_ROOT/%{_sysconfdir}/gconf/schemas
        for i in *.schemas; do
            mv $i helix-$i
        done
        popd
    %endif
%endif
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
#suse_update_desktop_file banshee  AudioVideo Player
%if %suse_version < 1030
    mkdir -p $RPM_BUILD_ROOT%{gstreamerprefix}/share
    mv $RPM_BUILD_ROOT%{prefix}/share/icons $RPM_BUILD_ROOT%{gstreamerprefix}/share/
%endif
%if %HELIX_BANSHEE == 1
    %suse_update_desktop_file "-C" "Play and organize music" "-G" "Music Player" "-N" "Helix Banshee" %{src_name}
%else
    %suse_update_desktop_file "-C" "Play and organize music" "-G" "Music Player" "-N" "Banshee" %{src_name}
%endif
%if %HELIX_BANSHEE == 1
    pushd ../helix-banshee-client-%{hxbc_version}
    export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
    make install DESTDIR=$RPM_BUILD_ROOT
    %if %suse_version < 1030
        rm -rf $RPM_BUILD_ROOT%{gstreamerprefix}/share/icons
        mv $RPM_BUILD_ROOT%{prefix}/share/icons $RPM_BUILD_ROOT%{gstreamerprefix}/share/
    %endif
    unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
    popd
    pushd ../gstreamer-xing-0.10.2
    make install DESTDIR=$RPM_BUILD_ROOT
    rm -f $RPM_BUILD_ROOT/%{gstreamerprefix}/%{_lib}/gstreamer-%{gst_branch}/*.*a
    # These two lines ensure gstreamer plugins installed become PRIVATE to Banshee
    mkdir -p $RPM_BUILD_ROOT/usr/%{_lib}/banshee/gstreamer-%{gst_branch}/
    mv $RPM_BUILD_ROOT/%{gstreamerprefix}/%{_lib}/gstreamer-%{gst_branch}/*.so $RPM_BUILD_ROOT/usr/%{_lib}/banshee/gstreamer-%{gst_branch}/
    popd
%endif
%if %suse_version >= 1030

%def_gconf_schemas %{name}

%add_gconf_schemas %{name}-core

%add_gconf_schemas %{name}-interface

%def_gconf_schemas %{name}-plugins-default

%add_gconf_schemas %{name}-plugin-audioscrobbler

%add_gconf_schemas %{name}-plugin-metadatasearcher

%add_gconf_schemas %{name}-plugin-mmkeys

%add_gconf_schemas %{name}-plugin-notificationarea

%def_gconf_schemas %{name}-plugins-extra

%add_gconf_schemas %{name}-plugin-recommendation

%add_gconf_schemas %{name}-plugin-minimode

%add_gconf_schemas %{name}-plugin-podcast

%add_gconf_schemas %{name}-plugin-radio

%add_gconf_schemas %{name}-plugin-bookmarks

%add_gconf_schemas %{name}-plugin-lastfm

%def_gconf_schemas %{name}-plugins-DAAP

%add_gconf_schemas %{name}-plugin-daap

%end_gconf_schemas
%endif
%if %suse_version >= 1030

%pre -f %{name}.schemas_pre

%pre plugins-default -f %{name}-plugins-default.schemas_pre

%pre plugins-extra -f %{name}-plugins-extra.schemas_pre

%pre plugins-DAAP -f %{name}-plugins-DAAP.schemas_pre
%endif

%post
%if %suse_version >= 1030
    if test -x usr/bin/update-mime-database ; then
        usr/bin/update-mime-database usr/share/mime >/dev/null
    fi
%else
    export GCONF_CONFIG_SOURCE=`%{gconf_config_source}`
    %{gconf_schema_install}/banshee-core.schemas > /dev/null
    %{gconf_schema_install}/banshee-interface.schemas > /dev/null
%endif
%run_ldconfig

%post plugins-default
%if %suse_version < 1030
export GCONF_CONFIG_SOURCE=`%{gconf_config_source}`
%{gconf_schema_install}/banshee-plugin-metadatasearcher.schemas > /dev/null
%{gconf_schema_install}/banshee-plugin-mmkeys.schemas > /dev/null
%{gconf_schema_install}/banshee-plugin-notificationarea.schemas > /dev/null
%endif

%post plugins-extra
%if %suse_version < 1030
export GCONF_CONFIG_SOURCE=`%{gconf_config_source}`
%{gconf_schema_install}/banshee-plugin-radio.schemas > /dev/null
%{gconf_schema_install}/banshee-plugin-podcast.schemas > /dev/null
%{gconf_schema_install}/banshee-plugin-minimode.schemas > /dev/null
%{gconf_schema_install}/banshee-plugin-recommendation.schemas > /dev/null
%{gconf_schema_install}/banshee-plugin-bookmarks.schemas > /dev/null
%{gconf_schema_install}/banshee-plugin-lastfm.schemas > /dev/null
%endif

%post plugins-DAAP
%if %suse_version < 1030
export GCONF_CONFIG_SOURCE=`%{gconf_config_source}`
%{gconf_schema_install}/banshee-plugin-daap.schemas > /dev/null
%endif
%if %suse_version >= 1030

%posttrans -f %{name}.schemas_posttrans

%posttrans plugins-default -f %{name}-plugins-default.schemas_posttrans

%posttrans plugins-extra -f %{name}-plugins-extra.schemas_posttrans

%posttrans plugins-DAAP -f %{name}-plugins-DAAP.schemas_posttrans
%endif
%if %suse_version >= 1030

%preun -f %{name}.schemas_preun

%preun plugins-default -f %{name}-plugins-default.schemas_preun

%preun plugins-extra -f %{name}-plugins-extra.schemas_preun

%preun plugins-DAAP -f %{name}-plugins-DAAP.schemas_preun
%endif

%clean
### rm -rf $RPM_BUILD_ROOT
%if %suse_version < 1030

%files 
%else

%files -f %{name}.schemas_list
%endif
%defattr(-,root,root)
%doc AUTHORS NEWS README COPYING
%{prefix}/bin/banshee
%dir %{prefix}/%{_lib}/banshee
%dir %{prefix}/%{_lib}/banshee/Banshee.Dap
%dir %{prefix}/%{_lib}/banshee/Banshee.MediaEngine
%dir %{prefix}/share/banshee
%dir %{prefix}/share/banshee/audio-profiles
%{prefix}/%{_lib}/banshee/*.so
%{prefix}/%{_lib}/banshee/banshee.exe*
%{prefix}/%{_lib}/banshee/Banshee.Base.dll*
%{prefix}/%{_lib}/banshee/Banshee.Widgets.dll*
%{prefix}/%{_lib}/banshee/Gnome.Keyring.dll*
%{prefix}/%{_lib}/banshee/Hal.dll*
%{prefix}/%{_lib}/banshee/Last.FM.dll*
%{prefix}/%{_lib}/banshee/MusicBrainz.dll*
%{prefix}/%{_lib}/banshee/TagLib.dll*
%{prefix}/%{_lib}/banshee/Boo*.dll*
%{prefix}/%{_lib}/banshee/Banshee.Dap/Banshee.Dap.MassStorage.dll*
%{prefix}/%{_lib}/banshee/Banshee.Dap/Banshee.Dap.Ipod.dll*
%{prefix}/%{_lib}/banshee/Banshee.Dap/ipod-sharp.dll*
%{prefix}/%{_lib}/banshee/Banshee.Dap/ipod-sharp-ui.dll*
%if %HELIX_BANSHEE == 1
    %{prefix}/%{_lib}/banshee/branding.dll
%endif
%{prefix}/share/applications/banshee.desktop
%{prefix}/share/dbus-1/services/org.gnome.Banshee.service
%{prefix}/share/locale/*/LC_MESSAGES/banshee.mo
%{prefix}/share/banshee/audio-profiles/*.xml
%if %suse_version < 1030
    %{sysconfdir}/gconf/schemas/banshee-interface.schemas
    %{sysconfdir}/gconf/schemas/banshee-core.schemas
%endif
%{gstreamerprefix}/share/icons/hicolor/16x16/apps/music-player-banshee.png
%{gstreamerprefix}/share/icons/hicolor/22x22/apps/music-player-banshee.png
%{gstreamerprefix}/share/icons/hicolor/24x24/apps/music-player-banshee.png
%{gstreamerprefix}/share/icons/hicolor/32x32/apps/music-player-banshee.png
%{gstreamerprefix}/share/icons/hicolor/48x48/apps/music-player-banshee.png
%{gstreamerprefix}/share/icons/hicolor/192x192/apps/music-player-banshee.png
#%{prefix}/%{_lib}/monodoc/sources/banshee-docs.source
#%{prefix}/%{_lib}/monodoc/sources/banshee-docs.tree
#%{prefix}/%{_lib}/monodoc/sources/banshee-docs.zip

%files devel
%defattr(-,root,root)
%{prefix}/%{_lib}/banshee/*.*a
%{prefix}/%{_lib}/pkgconfig/banshee.pc
%{prefix}/%{_lib}/banshee/gconf-schema-extractor.exe

%files engine-gst
%defattr(-,root,root)
%dir %{prefix}/%{_lib}/banshee/Banshee.MediaEngine
%{prefix}/%{_lib}/banshee/Banshee.MediaEngine/Banshee.MediaEngine.GStreamer.dll*
%if %HELIX_BANSHEE == 1

%files engine-helix
%defattr(-,root,root)
%dir %{prefix}/%{_lib}/banshee/Banshee.MediaEngine
%dir %{prefix}/%{_lib}/banshee/gstreamer-%{gst_branch}
%{prefix}/%{_lib}/banshee/gstreamer-%{gst_branch}/*.so
%ifarch %ix86 x86_64
%{prefix}/%{_lib}/banshee/Banshee.MediaEngine/Banshee.MediaEngine.HelixRemote.dll*
%{prefix}/%{_lib}/banshee/transwav
%endif
%endif
%if %suse_version < 1030

%files plugins-default 
%else

%files plugins-default -f %{name}-plugins-default.schemas_list
%endif
%defattr(-,root,root)
%if %suse_version < 1030
%{sysconfdir}/gconf/schemas/banshee-plugin-audioscrobbler.schemas
%{sysconfdir}/gconf/schemas/banshee-plugin-metadatasearcher.schemas
%{sysconfdir}/gconf/schemas/banshee-plugin-mmkeys.schemas
%{sysconfdir}/gconf/schemas/banshee-plugin-notificationarea.schemas
%endif
%dir %{prefix}/%{_lib}/banshee/Banshee.Plugins
%{prefix}/%{_lib}/banshee/Banshee.Plugins/Banshee.Plugins.Audioscrobbler.dll*
%{prefix}/%{_lib}/banshee/Banshee.Plugins/Banshee.Plugins.MMKeys.dll*
%{prefix}/%{_lib}/banshee/Banshee.Plugins/Banshee.Plugins.MetadataSearch.dll*
%{prefix}/%{_lib}/banshee/Banshee.Plugins/Banshee.Plugins.NotificationAreaIcon.dll*
%if %suse_version < 1030

%files plugins-extra
%else

%files plugins-extra -f %{name}-plugins-extra.schemas_list
%endif
%defattr(-,root,root)
%if %suse_version < 1030
%{sysconfdir}/gconf/schemas/banshee-plugin-recommendation.schemas
%{sysconfdir}/gconf/schemas/banshee-plugin-minimode.schemas
%{sysconfdir}/gconf/schemas/banshee-plugin-podcast.schemas
%{sysconfdir}/gconf/schemas/banshee-plugin-radio.schemas
%{sysconfdir}/gconf/schemas/banshee-plugin-bookmarks.schemas
%{sysconfdir}/gconf/schemas/banshee-plugin-lastfm.schemas
%endif
%dir %{prefix}/%{_lib}/banshee/Banshee.Plugins
%{prefix}/%{_lib}/banshee/Banshee.Plugins/Banshee.Plugins.MiniMode.dll*
%{prefix}/%{_lib}/banshee/Banshee.Plugins/Banshee.Plugins.Podcast.dll*
%{prefix}/%{_lib}/banshee/Banshee.Plugins/Banshee.Plugins.Recommendation.dll*
%{prefix}/%{_lib}/banshee/Banshee.Plugins/Banshee.Plugins.Radio.dll*
%{prefix}/%{_lib}/banshee/Banshee.Plugins/Banshee.Plugins.Bookmarks.dll*
%{prefix}/%{_lib}/banshee/Banshee.Plugins/Banshee.Plugins.LastFM.dll*
%if %suse_version < 1030

%files plugins-DAAP
%else

%files plugins-DAAP -f %{name}-plugins-DAAP.schemas_list
%endif
%defattr(-,root,root)
%if %suse_version < 1030
%{sysconfdir}/gconf/schemas/banshee-plugin-daap.schemas
%endif
%dir %{prefix}/%{_lib}/banshee/Banshee.Plugins
%{prefix}/%{_lib}/banshee/Banshee.Plugins/Banshee.Plugins.Daap.dll*

%changelog
* Fri May 25 2007 - ro@suse.de
- remove X-SuSE-Translate from desktop file
- do not call suse_update_desktop file twice
* Sat Apr 07 2007 - abockover@suse.de
- Added more translations from SLED SP1
- Removed old banshee-0.12.0 tarball
* Fri Apr 06 2007 - maw@suse.de
- Update to version 0.12.1
- Fixes for #257156, #239013, and #239107
- Support iTunes 7.1, HFS+ iPods, and iPod Shuffle 2nd generations
* Fri Apr 06 2007 - maw@suse.de
- Fix the build for helix-banshee as well -- use pushd/popd
  instead of cd in the %%install section
- Rename the schemas installed with helix-banshee from
  banshee*schemas to helix-banshee*schemas.
* Thu Apr 05 2007 - maw@suse.de
- Fix the build
  * Package certain hitherto unpackaged files in both banshee and
  helix-banshee
  * Use the wacky fun magic gconf scripts.
- helix-banshee.spec is created as a copy of banshee.spec with
  a few things changed.  This is now performed via the small
  script helix-banshee-fixup.sh.  If the two specs diverge further,
  the script can be enhanced.
* Tue Mar 27 2007 - sbrabec@suse.cz
- Build correctly with avahi-mono in GNOME Build Service.
* Thu Mar 08 2007 - sbrabec@suse.cz
- Removed obsolete hicolor icon symlink (#248676).
* Mon Mar 05 2007 - abockover@suse.de
- Updated to 0.12.0
  * 200068 - Suspend crasher
  * 218228 - Do not overwrite GST_PLUGIN_PATH
  * 228720 - Fix playing icon duplication
  * 248422 - Fix potential constant rebuffering
  * 248831 - Show user defined stations even if remote ones can't be shown
  * Upstream/BGO Fixes: 414505, 414485, 413593, 410364, 348079, 408128,
  411221, 410278, 408068
  * Czech, French, Hungarian translations updated from upstream
* Sun Feb 11 2007 - aj@suse.de
- Fix last change.
* Fri Feb 09 2007 - sbrabec@suse.cz
- Removed obsolete upgrade hacks (#237659).
* Mon Feb 05 2007 - abockover@suse.de
- Updated to 0.11.6
- BNC Fixes: 236428, 236798, 237560, 239102, 237038, 237045
- BGO Fixes: 399462, 398491, 399650, 342942
- Support local radio station management
- Usability and UI fixes/polish
* Thu Jan 25 2007 - abockover@suse.de
- Updated to 0.11.5
- Same spec file can be used for 10.1 through STABLE
* Wed Jan 24 2007 - aj@suse.de
- Add icon.
* Mon Jan 22 2007 - aj@suse.de
- Adjust for GNOME move to /usr.
- Use avahi instead of mDNSResponder.
* Thu Jan 04 2007 - sbrabec@suse.cz
- Reflect gstreamer010-plugins-base merge.
* Fri Nov 17 2006 - meissner@suse.de
- require gstreamer010-plugins-base-oil, or OGGs won't play. #221652
* Thu Nov 09 2006 - aj@suse.de
- Fix require for banshee-engine.
* Wed Nov 08 2006 - aj@suse.de
- Add recommends for subpackages.
* Tue Nov 07 2006 - cthiel@suse.de
- Conflicts: helix-banshee
- Provides:  banshee-player
* Mon Nov 06 2006 - abockover@suse.de
- Changes to spec file to make it easy to build either upstream
  (open source) Banshee or Helix Banshee with proprietary
  components
* Wed Nov 01 2006 - olh@suse.de
- helix-dbus-server is i386 only
* Mon Oct 23 2006 - abockover@suse.de
- Updated to 0.11.2
  * New interactive interpreted Boo shell
  * Show DAAP shares under single master source (BGO #363548)
  * Recursive child sources now possible (BGO #363548)
  * Load XML audio profiles from multiple sources
  * Fixed sorting issue with audio profiles combo control
  * Added 'mode' suppport to mp3-lame audio profile
  * Load audio profiles from BANSHEE_PROFILES_PATH env if set
  * New SQL Database command layer for more secure and
  optimized queries (BNC #212477)
  * Do not require intltool 0.35
  * Worked around various build problems with Mono 1.1.18
* Fri Oct 20 2006 - ro@suse.de
- added mono-devel to BuildRequires
* Mon Oct 16 2006 - abockover@suse.de
- Updated to 0.11.1
  * Many new features and bug fixes; first update to new branch
  * Import from DAP devices and DAAP shares
  * Write metadata to files
  * New tagging backend (taglib-sharp)
  * New track editor
  * New CD burning interface
  * Smart playlists
  * One click rating
  * Simplified preferences dialog following GNOME HIG
  * Notifications on track change
  * New audio profiles support
  * Use managed dbus (not deprecated dbus-sharp+libdbus)
* Thu Sep 28 2006 - ro@suse.de
- fix macro usage in specfile: dbus-version -> dbus_min_version
  (#206627)
* Tue Sep 12 2006 - ro@suse.de
- use RPM_OPT_FLAGS
- fix missing return values in xing encoder
- fix build on x86_64
* Mon Aug 28 2006 - jpr@suse.de
- No longer have to manually remove file notification plugin, its been
  removed upstream
* Thu Aug 24 2006 - jpr@suse.de
- Updated to 0.10.12
  * Work with libnautilus-burn 2.15.3+ (emulation layer for 2.12/2.14 API)
  * Added CD-ROM door locking (BNC #199902)
  * Do not crash on exit if events have come from NetworkManager
  * Translations update
  * The cover art popup will scale to a maximum of 75%% of the screen
  * Handle exception when trying to burn CD on a system with no CD writers
  * Fix a crash when attempting to remove a track from the local queue
  * Build properly with Gtk# 2.10
  * Much improved NJB DAP support [1]
  * Much improved CD burning (show error dialog with list of files that
  cannot be transcoded, fixed MP3/Data CD support, check for enough
  available disk space to perform transcoding)
  * Fixed locking bug that causes crashes (BGO #340306)
  * Fixed HTTP/Streaming support in Helix backend
  * Prevent crash when dragging a column into the source view
  (BGO #333946)
  * Prevent crash when removing the playing song (BGO #324768)
  * Prevent Banshee crash if gnome-panel crashes
  * Remove tooltip from slider (BNC #158403)
  * Properly activate org.gnome.HelixDbusPlayer using DBus activation
  (BNC #161682)
  * Fixed dynamic player engine switching (GStreamer<->Helix)
  * Prefer a stream duration over a metadata duration at all times
  * Insert oggmux into a vorbisenc pipeline if oggmux is missing
  (BGO #335211)
- Remove upstreamed patches
- Remove upstreamed translation sources
* Tue Aug 22 2006 - sbrabec@suse.cz
- Worked around upgrade failures due to insufficient PreReq for
  gst-register in older versions (#165811).
* Thu Jul 13 2006 - hvogel@suse.de
- require gnome-vfs2 for gst-inspect
* Wed Jun 28 2006 - gekker@suse.de
- Update translations for hu
* Tue Jun 27 2006 - jpr@suse.de
- Make sure all mp4 mime types are listed (#188200)
* Mon Jun 26 2006 - gekker@suse.de
- Update translations for zh_TW
* Thu Jun 22 2006 - gekker@suse.de
- Update translations for de
* Wed Jun 21 2006 - gekker@suse.de
- Add EULAs for other locales (#186272)
* Mon Jun 19 2006 - gekker@suse.de
- Update EULA.en_US from Real (#186272)
* Mon Jun 19 2006 - lewing@suse.de
- Finish startup nofication in remote mode. (#185212)
* Fri Jun 16 2006 - gekker@suse.de
- Update translations for de,ja and add translation for pl
* Wed Jun 14 2006 - gekker@suse.de
- Add Helix branded icons
* Wed Jun 14 2006 - gekker@suse.de
- Update Helix branding
* Tue Jun 13 2006 - gekker@suse.de
- Fix mime mappings in banshee.desktop to support mp3 (#183032)
* Fri Jun 09 2006 - gekker@suse.de
- Update translation for cs
* Mon Jun 05 2006 - jpr@suse.de
- Add helix branding (#181841)
* Fri Jun 02 2006 - gekker@suse.de
- Update translation for de
* Thu Jun 01 2006 - jpr@suse.de
- Restore volume properly (#176255)
- Actually display the dialog when CD burn is too big (#151332)
- Don't have the mp3 plugins system wide (#179102)
* Wed May 31 2006 - gekker@suse.de
- Update translations for zh_CN (#169091)
* Tue May 30 2006 - gekker@suse.de
- Add translations for zh_TW, update translations for de,es,fi,
  fr,hu,it,ja,pt_BR,zh_CN
* Mon May 22 2006 - jpr@suse.de
- Build and install dtdriver plugin for 32bit at atleast (#177506)
* Fri May 19 2006 - jpr@suse.de
-Improve SQL queries to improve performance (#168653)
-Escape commas correclty (#147144)
-Scrollbar does not show (#174406)
-Column re-ordering remembered incorrectly (#120666)
-Fix crash on CD burn for ogg (#175378)
-Move the xing plugin to the banshe-engine-helix package
* Wed May 17 2006 - gekker@suse.de
- Add translations for de and hu (#173507)
* Thu May 11 2006 - rml@suse.de
- Add requires on dbus-1-x11, as we use the session bus (Novell
  bug #174865)
* Mon May 08 2006 - jpr@suse.de
- Trigger default dialog action with return, not esc (#172450)
- Copy music to music directory when option selected (#171101)
- Play files in shallow directories (#163911)
- Default to gstreamer for ogg play to work around helix memory leak
  (part of #170031)
* Mon May 08 2006 - thoenig@suse.de
- Loosing D-BUS requires (b.n.c #173483)
* Thu May 04 2006 - jpr@suse.de
- Handle new ogg subclass (#169616)
- Prevent crash while doing long import (BGO #340306)
- Display ipod correctly if banshee is already running(BGO #340313)
* Wed Apr 26 2006 - aj@suse.de
- Fix build on lib64 systems.
* Mon Apr 24 2006 - jpr@suse.de
- Don't package FileSystemMonitor plugin, its not in a happy state
- Fix dell dj support with njb-sharp update and hal files
- Check data length before trying to convert to string and catch any
  exceptions in the conversion (BGO #333946)
- Call model.RemoveTrack instead of model.Remove (BGO #324768)
- If the removed iter is the playing iter, set the playing iter to
  zero (BGO #324768)
- Re-enable http support in the helix backend now that we have a
  workaround in helix-dbus-server
* Mon Apr 24 2006 - thoenig@suse.de
- Add patch banshee-networkmanager-reconnect.diff to make Banshee
  resistant against D-BUS restarts (#167824).
- Add Requires for dbus-1-mono-0.60-27 or higher.
* Wed Apr 12 2006 - gekker@suse.de
- Fix to build xing encoder on all archs (#165454)
* Mon Apr 10 2006 - jpr@suse.de
- Don't show error dialog if there were no errors burning the CD
  (#164910)
- Banshee crashes if panel dies (#164909)
* Sun Apr 09 2006 - aj@suse.de
- Fix Requires.
* Fri Apr 07 2006 - jpr@suse.de
- Improved initial import dialog and mimetype detection for importing (#130713)
- Check to see if files exist before burning, warn if they don't. Fixes crash. (#146334)
- Ensure any files Banshee has open on an iPod are closed before ejecting through HAL. (#158284)
- Removed position tooltip from slider widget (#158403)
- Do not try to play audio through Helix that it cannot support. Divert crash in Helix. (#159810)
- Only show the actual track that is playing in the view, not multiples with matching metadata. (#160186)
- Fixed seeking over DBus with Helix (#161093)
* Mon Apr 03 2006 - jpr@suse.de
- Update to banshee 0.10.9 plus patch of 0.10 branch upstream
  exclusively for SLED issues
- Includes gstreamer 0.10 support and updates including xing
- Fix CD play back crash (#159414)
- Fix helix-dbus-server activation issues (#161682)
- Fix automatic engine switching for WMA, FLAC, MP3 (#160675)
- Fix track lengths time as best possible when metadata is wrong (#133717)
- Don't allow play and rip at the same time, only allow play back of the ripped tracks (#162171)
* Wed Mar 29 2006 - gekker@suse.de
- Add mDNSResponder mDNSResponder-devel to BuildRequires
* Mon Mar 27 2006 - gekker@suse.de
- Split out DAAP plugin and mDNSResponder dep (#160630)
* Sun Mar 19 2006 - danw@suse.de
- Fix back/play/pause/forward icons under kde. #148034
* Thu Mar 16 2006 - jpr@suse.de
- Make sure we default to the new remote helix engine.
* Tue Mar 14 2006 - gekker@suse.de
- Update to version 0.10.8/Remove upstreamed patches
- Includes fix for using helix-dbus-server to use helix backend
  on x86_64 (#116926)
- Don't add docpath to desktop, since there are no docs (#157779)
- Includes other upstream bug fixes
* Tue Mar 07 2006 - gekker@suse.de
- Fix segfault (#155850)
* Tue Mar 07 2006 - gekker@suse.de
- Update to version 0.10.7
- Remove avahi-mono from BuildRequires
  NEW FEATURES
------------
  * Full GStreamer 0.10 support
  * New importing system and UI; plugins can provide custom import sources
  * Bonjour/mDNSResponder support in addition to Avahi for Zeroconf support
  * Genre playlist column and entry in track editor
  * Shuffle button now has the same behavior as the repeat button
  * New translations: British English (Christopher Orr), Finnish (Ilkka Tuohela),
  and Italian (Alessandro Gervaso)
  BUG FIXES
---------
  * 324924: Systemtray does not appear
  * 326915: Automatic syncronization with an iPod hangs
  * 328183: Multiple manual syncronizations of an iPod cause it to corrupt its database
  * 329645: Cover art flashing
  * 329966: CDs Fail to Show Up in Library List
  * 330003: Banshee crash loading NotificationAreaIcon
  * 330284: crash at startup with daap plugin when there is a daap share on the network
  * 330524: [PATCH] Doesn't adjust volume when scrolling over the volume widget
  * 330903: [PATCH] Banshee crashes when requesting album cover for an album without one
  * 332350: [PATCH] make banshee use gconf audio sink with gstreamer 0.10
  * 326876: daap shares not being removed
* Mon Mar 06 2006 - gekker@suse.de
- Enable DAAP support
* Mon Feb 27 2006 - gekker@suse.de
- Fix missing columns in banshee (#153153)
* Fri Feb 24 2006 - sbrabec@suse.cz
- Fixed Czech translation.
* Thu Feb 23 2006 - danw@suse.de
- add banshee-transparent-trayicon.patch to make the tray icon pretty
  under KDE. #135448
* Sun Feb 19 2006 - aj@suse.de
-  use wildcards in filelist (.mdb files moved to debuginfo package)
* Fri Feb 17 2006 - gekker@suse.de
- Fixup .desktop file for UI team
* Mon Feb 13 2006 - gekker@suse.de
- Update to version 0.10.6
- Remove upstreamed patch
  This release features much improved iPod support. A few large bugs were
  fixed regarding iPod syncing, and a database reconstruction was added
  if Banshee ever encounters an iPod database it cannot read (iTunes frequently
  updates the database format).
  * If an unsupported iPod database is encountered, Banshee will offer
  to scan the iPod and reconstruct a database; either way, unsupported
  database errors are handled very gracefully now
  * Use cover.jpg/folder.jpg and others as cover art if it exists
  * Improved startup time
  * ipod-sharp now has fixed logic for syncing, fixes a few bugs
  * 324326: iPod transcoding dies on filenames containing %
  * 324923: Banshee crash on clicking any menu item
  * 326947: Visibility of Rating/Plays/LastPlayed columns are reset to default
  * 327225: Banshee should listen for multimedia keypresses
  * 328183: Multiple manual syncronizations of an iPod cause it to corrupt its database
  * 328642: Simple right-click meno on tray icon
  * 329540: banshee wrapper script looks for executable in CWD
  * 329554: cursor jumps from new list to the search box
  * 330288: crash on amd64 when playing ANY file
  * 330524: [PATCH] Doesn't adjust volume when scrolling over the volume widget
  * 330903: [PATCH] Banshee crashes when requesting album cover for an album without one
* Thu Feb 09 2006 - ro@suse.de
- fix configure check for mono assemblies
* Tue Feb 07 2006 - gekker@suse.de
- Update to version 0.10.5
  NEW FEATURES
------------
  * New queued/single-threaded database layer; much safer and potentially
  faster in some areas
  * Multimedia keys plugin by Danilo Reinhardt
  * Improved custom source API. Sources can now provide custom or hybrid
  views. See the banshee-sample-plugin module in Banshee subversion:
  svn://svn.banshee-project.org/trunk/banshee-sample-plugin
  * Improved search entry; uses stock/theme icons now
  * Improved volume widget; +/- are now clickable (Ruben Vermeersch)
  * Banshee now shows up in process listings (top, gnome system monitor)
  as 'banshee' (not 'mono'); and 'killall banshee' will now work
  BUG FIXES
---------
  * 320608: "Copy files on import" option can kill files.
  * 320799: Left pane stays empty because of markup problems
  * 324143: Playlist initially displays library contents
  * 324326: iPod transcoding dies on filenames containing %
  * 324923: Banshee crash on clicking any menu item
  * 325078: Updating the preferences of a song doesn't refresh
  * 325636: Banshee consumes CPU even when not playing
  * 325770: Crash in 0.10.2 with GStreamer 0.10
  * 325956: Metadata Searcher freezes after ~100 tracks
  * 326836: Dragging a track to ipod causes crash on exit
  * 326863: Crash on metadata scan.
  * 326922: Can't execute uninstalled banshee
  * 327046: org.gnome.Banshee.service installed in wrong directory
  * 327047: menu entry Music/Source Properties... has no effect
  * 327123: random playback isnt working correctling when banshee is
  started
  * 328058: Database locking issues with metadata plugin enabled
  * 328642: Simple right-click meno on tray icon
  * 328916: Compile fails to detect Mono on AMD64 systems
  * 329012: Using "libdbus-1.so.1" for DllImport can fail (libdbus-1.so.2
  present)
  * 329292: use/detect search and close icons for the search box from the
  GTK theme
  * 329540: banshee wrapper script looks for executable in CWD
  * 329554: cursor jumps from new list to the search box
  * 329875: Banshee should use standard volume button
  * 328201: add --query-cover-uri
* Mon Feb 06 2006 - ro@suse.de
- fix build for < 10.1
* Fri Feb 03 2006 - aj@suse.de
- Add gcc-c++ to BuildRequires.
* Wed Feb 01 2006 - aj@suse.de
- Fix typo in last change.
* Tue Jan 31 2006 - aj@suse.de
- Remove unneeded requires.
- Cleanup BuildRequires.
* Wed Jan 25 2006 - mls@suse.de
- converted neededforbuild to BuildRequires
* Tue Jan 17 2006 - gekker@suse.de
- Update to version 0.10.4
* Tue Jan 17 2006 - gekker@suse.de
- Update to version 0.10.3
- Disable daap for now
- Split out plugins into their own package
* Tue Jan 17 2006 - meissner@suse.de
- use -fstack-protector.
* Fri Jan 13 2006 - gekker@suse.de
- Fixup nfb and Requires for new gtk-sharp2 packaging
* Wed Jan 04 2006 - gekker@suse.de
- Fix to install all .schema files
- Fix hal-sharp bindings to locate new .so version of dbus
* Fri Dec 23 2005 - gekker@suse.de
- Update to version 0.10.2
  - Adds NJB support
  - Adds plugin support
  - Audioscrobbler plugin
  - NetworkManager support
  - More commandline options
* Thu Dec 15 2005 - gekker@suse.de
- Update to version 0.10.1
* Mon Dec 12 2005 - gekker@suse.de
- Fixup provides in banshee-engine-* (#135353)
* Thu Dec 08 2005 - gekker@suse.de
- Fix audio CD playing
* Wed Dec 07 2005 - gekker@suse.de
- Update to version 0.10
* Mon Nov 28 2005 - gekker@suse.de
- Add PreReq: gstreamer (#135353).
* Wed Nov 16 2005 - ro@suse.de
- fix build on x86_64 (-p for mkdir)
* Wed Nov 16 2005 - jpr@suse.de
- Fix error mono errors with new gtk-sharp
* Mon Nov 14 2005 - jpr@suse.de
- Update to 0.9.11.1
* Thu Nov 10 2005 - jpr@suse.de
- Update to 0.9.11
* Fri Nov 04 2005 - sbrabec@suse.cz
- Call branch-dependent gst-register (#132197).
* Thu Nov 03 2005 - gekker@suse.de
- Update to version 0.9.10
- Fixup Requires and Provides (#129720)
- Add libmusicbrainz to nfb
- Remove upstreamed patches
- Build --with-internal-mcs on PLUS
* Thu Sep 29 2005 - sbrabec@suse.cz
- Use secure paths in wrapper (#118188).
- Bi-arch fix of aoss preloader (#119413).
* Wed Sep 28 2005 - gekker@suse.de
- Update to version 0.9.7.1
- Add nano support
* Mon Sep 19 2005 - gekker@suse.de
- Add extra and excess gstreamer plugins to requirements (116924)
* Sat Sep 10 2005 - jpr@suse.de
- Fix typo in preload patch, its LD_PRELOAD not LD_PRELOADH
- Fix crash when no ipod compatible encoders are available (as is
  the case on non x86 platforms) (116303)
* Fri Sep 09 2005 - gekker@suse.de
- Update to version 0.9.7 for shuffle support
- Fix crash when re-ripping a song (115945)
- Fix default width of columns
- Fix a marshalling bug on 64-bit
- Fix crashes in banshes (116164)
* Wed Sep 07 2005 - gekker@suse.de
- Add gst-register to %%post of banshee-engine-gst (115275)
- Add dbus-1-x11 to Requires (114493)
* Mon Sep 05 2005 - jpr@suse.de
- Update to version 0.9.6
- Add orbit/libidl for neededtobuild for using gnome cddb support
* Mon Sep 05 2005 - jpr@suse.de
- Update to verison 0.9.5
- LD_PPRELOAD libaoss to prevent locking of /dev/dsp
* Mon Aug 29 2005 - gekker@suse.de
- Update to version 0.9.0
- Require sqlite rather than sqlite2
* Mon Aug 22 2005 - gekker@suse.de
- Fix exe.config.in again so that it will actually run.
* Mon Aug 22 2005 - gekker@suse.de
- Update to version 0.8.7.1
- Split out -engine-gst and -engine-helix packages from banshee
- Add gnome-vfs2 to nfb
* Sun Aug 21 2005 - ro@suse.de
- added fam to nfb
* Tue Aug 16 2005 - aj@suse.de
- Add check-build script.
* Mon Aug 15 2005 - gekker@suse.de
- Update to version 0.8.5
* Fri Aug 12 2005 - gekker@suse.de
- Update to version 0.8.4
* Fri Aug 12 2005 - ro@suse.de
- more work on exe-config patch: libdir already has prefix
* Thu Aug 11 2005 - gekker@suse.de
- Fix to find gstreamer libraries on all architectures
* Tue Aug 09 2005 - gekker@suse.de
- Update to version 0.8.3
- Improves use of gstreamer-backend
- Fix random return and exe.config.in with patches
* Fri Aug 05 2005 - clahey@suse.de
- Renamed from sonance.  Version 0.8.2.
* Wed Jul 06 2005 - gekker@suse.de
- Initial import of package, version 0.7.1
openSUSE Build Service is sponsored by