File python-oslo.context.spec of Package python-oslo.context
#
# spec file for package python-oslo.context
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%bcond_without test
Name: python-oslo.context
Version: 2.20.0
Release: 0
Summary: OpenStack Oslo context library
License: Apache-2.0
Group: Development/Languages/Python
Url: https://launchpad.net/oslo.context
Source0: https://files.pythonhosted.org/packages/source/o/oslo.context/oslo.context-2.20.0.tar.gz
BuildRequires: openstack-macros
BuildRequires: python2-pbr >= 2.0.0
BuildRequires: python2-positional
BuildRequires: python3-pbr >= 2.0.0
BuildRequires: python3-positional
Requires: python-debtcollector >= 1.2.0
Requires: python-positional
BuildArch: noarch
%if %{with test}
BuildRequires: python2-debtcollector >= 1.2.0
BuildRequires: python2-oslotest >= 3.2.0
BuildRequires: python3-debtcollector >= 1.2.0
BuildRequires: python3-oslotest >= 3.2.0
%endif
%python_subpackages
%description
The Oslo context library has helpers to maintain useful information
about a request context.
The request context is usually populated in the WSGI pipeline and
used by various modules such as logging.
%package -n python-oslo.context-doc
Summary: Documentation for OpenStack common context library
Group: Documentation/HTML
BuildRequires: python-Sphinx
BuildRequires: python-openstackdocstheme >= 1.18.1
%description -n python-oslo.context-doc
Documentation for the oslo-context library.
%prep
%autosetup -p1 -n oslo.context-2.20.0
%py_req_cleanup
# without git, openstackdocstheme has warnings which let the doc build fail
sed -i 's/^warning-is-error.*/warning-is-error = 0/g' setup.cfg
%build
%{python_build}
# generate html docs
%{__python2} setup.py build_sphinx
# remove the sphinx-build leftovers
rm -rf doc/build/html/.{doctrees,buildinfo}
%install
%{python_install}
%if %{with test}
%check
%{python_expand rm -rf .testrepository
$python setup.py testr
}
%endif
%files %{python_files}
%license LICENSE
%doc README.rst
%{python2_sitelib}/oslo_context
%{python2_sitelib}/*.egg-info
%files -n python-oslo.context-doc
%license LICENSE
%doc doc/build/html
%changelog