File python-objectpath.spec of Package python-objectpath
#
# spec file for package python-objectpath
#
# Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%else
BuildArch: noarch
%endif
%if 0%{?suse_version} >= 1500
%define pyth python3
%define py_sitelib %{python3_sitelib}
%else
%define pyth python
%define py_sitelib %{python_sitelib}
%endif
Name: %{pyth}-objectpath
Version: 0.5
Release: 0
License: AGPL-3.0
Summary: The agile NoSQL query language for semi-structured data
Url: http://github.com/dsc/bunch
Group: Development/Languages/Python
Source: https://pypi.python.org/packages/source/o/objectpath/objectpath-%{version}.tar.gz
BuildRequires: %{pyth}-devel
BuildRequires: %{pyth}-setuptools
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
ObjectPath is a query language similar to XPath or JSONPath, but much more
powerful thanks to embedded arithmetic calculations, comparison mechanisms and
built-in functions. This makes the language more like SQL in terms of
expressiveness, but it works over JSON documents rather than relations.
ObjectPath can be considered a full-featured expression language. Besides
selector mechanism there is also boolean logic, type system and string
concatenation available. On top of that, the language implementations (Python
at the moment; Javascript is in beta!) are secure and relatively fast.
%prep
%setup -q -n objectpath-%{version}
%build
%pyth setup.py build
%install
%pyth setup.py install --prefix=%{_prefix} --root=%{buildroot}
%files
%defattr(-,root,root,-)
%doc README.rst
%{py_sitelib}/*
%{_bindir}/objectpath
%changelog