File python-metatools.spec of Package python-metatools
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
%global pyname metatools
Summary: Python Metaclass Construction Tools
Name: python-%{pyname}
Version: 4a08c75
Release: 0
License: GPL-3.0+
Group: Development/Libraries/Python
# Downloaded source then recompressed with bz2
# https://github.com/klmitch/metatools/zipball/4a08c75c
Source: %{pyname}-git-master-%{version}.tar.bz2
Url: http://github.com/klmitch/metatools/
BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
BuildRequires: python
BuildRequires: python-setuptools
Requires: python
%description
This package contains the `metatools` module, which provides a
utility class (`MetaClass`) which metaclasses can extend. It
provides three static methods (available only on classes inheriting
from `MetaClass`; they will not clutter up your actual classes)
which can be used to enhance inheritance.
%prep
%setup -n %{pyname}-git-master-%{version}
%build
python setup.py build
%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
%clean
rm -rf %{buildroot}
%files
%defattr(-,root,root)
%doc COPYING README.rst
%{python_sitelib}/*
%changelog