File python-repoze.lru.spec of Package python-repoze.lru
#
# spec file for package python-repoze.lru
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
Name: python-repoze.lru
Version: 0.5
Release: 0
License: SUSE-Repoze
Summary: A tiny LRU cache implementation and decorator
Url: http://www.repoze.org
Group: Development/Languages/Python
Source: http://pypi.python.org/packages/source/r/repoze.lru/repoze.lru-%{version}.tar.gz
BuildRequires: python-devel
BuildRequires: python-distribute
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%else
BuildArch: noarch
%endif
%description
repoze.lru is a LRU (least recently used) cache implementation. Keys and
values that are not used frequently will be evicted from the cache faster
than keys and values that are used frequently. It works under Python 2.5,
Python 2.6, Python 2.7, and Python 3.2.
%prep
%setup -q -n repoze.lru-%{version}
%build
python setup.py build
%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
%files
%defattr(-,root,root,-)
%doc CHANGES.txt COPYRIGHT.txt LICENSE.txt README.txt
%{python_sitelib}/*
%changelog