File python3-Mako.spec of Package python-Mako

#
# spec file for package python3-Mako
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           python3-Mako
Version:        0.7.3
Release:        0
Url:            http://www.makotemplates.org/
Summary:        A super-fast Python templating language
License:        MIT
Group:          Development/Languages/Python
Source:         http://pypi.python.org/packages/source/M/Mako/Mako-%{version}.tar.gz
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  python3
BuildRequires:  python3-2to3
BuildRequires:  python3-MarkupSafe
BuildRequires:  python3-devel
BuildRequires:  python3-distribute
BuildRequires:  python3-nose
Requires:       python3-Beaker >= 1.1
Requires:       python3-MarkupSafe
BuildArch:      noarch

%description
Mako is a template library written in Python. It provides a familiar, non-XML 
syntax which compiles into Python modules for maximum performance. Mako's 
syntax and API borrows from the best ideas of many others, including Django
templates, Cheetah, Myghty, and Genshi. Conceptually, Mako is an embedded 
Python (i.e. Python Server Page) language, which refines the familiar ideas
of componentized layout and inheritance to produce one of the most 
straightforward and flexible models available, while also maintaining close 
ties to Python calling and scoping semantics.

%prep
%setup -q -n Mako-%{version}

%build
2to3 --no-diffs -w mako test scripts/mako-render
python3 setup.py build

%install
python3 setup.py install --prefix=%{_prefix} --root=%{buildroot}
mv %{buildroot}%{_bindir}/mako-render %{buildroot}%{_bindir}/mako-render-%{py3_ver}

%check
python3 setup.py test

%files
%defattr(-,root,root,-)
%doc CHANGES LICENSE README.rst examples
%{_bindir}/mako-render-%{py3_ver}
%{python3_sitelib}/mako/
%{python3_sitelib}/Mako-%{version}-py%{py3_ver}.egg-info

%changelog
openSUSE Build Service is sponsored by