File python-alembic.spec of Package python-alembic
#
# spec file for package python-alembic
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: python-alembic
Version: 0.4.2
Release: 0
Url: http://bitbucket.org/zzzeek/alembic
Summary: A database migration tool for SQLAlchemy
License: MIT
Group: Development/Languages/Python
Source: http://pypi.python.org/packages/source/a/alembic/alembic-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildRequires: python-Mako
BuildRequires: python-SQLAlchemy >= 0.7.5
BuildRequires: python-argparse
BuildRequires: python-devel
BuildRequires: python-distribute
BuildRequires: python-nose >= 0.11
Requires: python-Mako
Requires: python-SQLAlchemy >= 0.7.5
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%else
BuildArch: noarch
%endif
%description
Alembic is a new database migrations tool, written by the author
of SQLAlchemy <http://www.sqlalchemy.org>. A migrations tool
offers the following functionality:
* Can emit ALTER statements to a database in order to change
the structure of tables and other constructs
* Provides a system whereby "migration scripts" may be constructed;
each script indicates a particular series of steps that can "upgrade" a
target database to a new version, and optionally a series of steps that can
"downgrade" similarly, doing the same steps in reverse.
* Allows the scripts to execute in some sequential manner.
%prep
%setup -q -n alembic-%{version}
mv docs html && rm -rf html/build
%build
python setup.py build
%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
#NOTE(saschpe): Check back
%if 0%{?suse_version} >= 1110
%check
nosetests
%endif
%files
%defattr(-,root,root,-)
%doc CHANGES LICENSE README.rst html
%{_bindir}/alembic
%{python_sitelib}/*
%changelog