File python-neutronclient.spec of Package python-neutronclient
#
# spec file for package python-neutronclient
#
# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%define component neutronclient
Name: python-neutronclient
Version: 2.3.4
Release: 0
Summary: Openstack Network (Quantum) API Client
License: Apache-2.0
Group: Development/Languages/Python
Url: http://launchpad.net/python-neutronclient
Source: http://tarballs.openstack.org/python-neutronclient/python-neutronclient-2.3.4.tar.gz
# https://review.openstack.org/68357
Patch0: 0001-Fix-listing-security-group-rules-when-there-are-too-.patch
# https://review.openstack.org/73226/
Patch1: 0001-Switch-over-to-mox3.patch
# Replace httplib2 with requests
Patch2: 0001-Use-requests-module-for-HTTP-HTTPS.patch
# Remove httplib2 from requirement
Patch3: 0002-Remove-httplib2-requirement.patch
BuildRequires: openstack-suse-macros
BuildRequires: python-base
BuildRequires: python-distribute
# Documentation build requirements:
BuildRequires: python-Sphinx
BuildRequires: python-nose
BuildRequires: python-pbr
BuildRequires: python-pyparsing >= 1.5.6
BuildRequires: python-requests >= 1.1
BuildRequires: python-simplejson
Requires: python >= 2.6.8
Requires: python-Babel >= 1.3
Requires: python-argparse
Requires: python-cliff >= 1.4.3
Requires: python-iso8601 >= 0.1.4
Requires: python-pbr >= 0.5.21
Requires: python-requests >= 1.1
Requires: python-simplejson >= 2.0.9
Requires: python-six >= 1.4.1
Provides: python-quantumclient = 2.2.3.1
Obsoletes: python-quantumclient < 2.2.3.1
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%else
BuildArch: noarch
%endif
%description
This is a client for the OpenStack Quantum API. There's a Python API (the
neutronclient module), and a command-line tool (quantum).
%package test
Summary: Openstack Network (Quantum) API Client - Testsuite
Group: System/Management
Provides: python-quantumclient-test = 2.2.3.1
Obsoletes: python-quantumclient-test < 2.2.3.1
Requires: %{name} = %{version}
Requires: python-cliff-tablib >= 1.0
Requires: python-coverage >= 3.6
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
Requires: python-discover
%endif
Requires: python-fixtures >= 0.3.14
Requires: python-mox3 >= 0.5.3
Requires: python-python-subunit
Requires: python-testrepository >= 0.0.17
Requires: python-testtools >= 0.9.32
%description test
This package contains testsuite files for %{name}.
%prep
%setup -q -n python-neutronclient-%{version}
%patch0 -p1
%patch1 -p1
%patch2 -p1
%patch3 -p1
%openstack_cleanup_prep
%build
python setup.py build
python setup.py build_sphinx
rm doc/build/html/.buildinfo
%install
python setup.py install --skip-build --prefix=%{_prefix} --root=%{buildroot}
### bash-completion
install -p -D -m 644 tools/neutron.bash_completion %{buildroot}%{_sysconfdir}/bash_completion.d/openstack-neutron.sh
### test subpackage
%openstack_test_package_install
%files
%defattr(-,root,root,-)
%doc LICENSE README.rst doc/build/html
%{_bindir}/neutron
%{_sysconfdir}/bash_completion.d/openstack-neutron.sh
%{python_sitelib}/%{component}/
%{python_sitelib}/python_%{component}-*.egg-info
%files test
%defattr(-,root,root,-)
%{_localstatedir}/lib/%{name}-test/
%changelog