File python-pep8.spec of Package python-pep8

#
# spec file for package python-pep8
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           python-pep8
Version:        1.4.5
Release:        0
Url:            http://github.com/jcrocholl/pep8
Summary:        Python style guide checker
License:        MIT
Group:          Development/Languages/Python
Source:         http://pypi.python.org/packages/source/p/pep8/pep8-%{version}.tar.gz
# PATCH-FIX-OPENSUSE: speilicke@suse.com -- Upstream forgot tox.init in sdist
# release, seems to be present in never codebase
Patch0:         no-tox-test.diff
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  fdupes
BuildRequires:  python-devel
BuildRequires:  python-distribute
%if 0%{?suse_version} <= 1110
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
%else
%py_requires
BuildArch:      noarch
%endif

%description
Pep8 is a tool to check your Python code against some of the style
conventions in PEP 8.

%prep
%setup -q -n pep8-%{version}
%patch0

%build
python setup.py build

%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
%fdupes %{buildroot}%{python_sitelib}

%check
python setup.py test

%files
%defattr(-,root,root)
%doc CHANGES.txt README.rst
%{_bindir}/pep8
%{python_sitelib}/pep8.py*
%{python_sitelib}/pep8-%{version}-py%{py_ver}.egg-info/

%changelog
openSUSE Build Service is sponsored by