File python-fixtures.spec of Package python-fixtures
#
# spec file for package python-fixtures
#
# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: python-fixtures
Version: 0.3.14
Release: 0
Summary: Fixtures, reusable state for writing clean tests and more
License: Apache-2.0 or BSD-3-Clause
Group: Development/Languages/Python
Url: https://launchpad.net/python-fixtures
Source: http://pypi.python.org/packages/source/f/fixtures/fixtures-%{version}.tar.gz
BuildRequires: python-devel
BuildRequires: python-testtools >= 0.9.22
# Test requirements:
#BuildRequires: python-bzrlib.tests
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
BuildRequires: python-discover
BuildRequires: python-unittest2
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%else
BuildArch: noarch
%endif
%description
Fixtures defines a Python contract for reusable state / support logic,
primarily for unit testing. Helper and adaption logic is included to make it
easy to write your own fixtures using the fixtures contract. Glue code is
provided that makes using fixtures that meet the Fixtures contract in unittest
compatible test cases easy and straight forward.
%prep
%setup -q -n fixtures-%{version}
%build
python setup.py build
%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
%check
python -m testtools.run discover
%files
%defattr(-,root,root,-)
%doc Apache-2.0 BSD COPYING NEWS README
%{python_sitelib}/*
%changelog