File python-ply.spec of Package python-ply

#
# spec file for package python-ply
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%define modname ply
Name:           python-%{modname}
Version:        3.4
Release:        0
Url:            http://www.dabeaz.com/ply/
Summary:        Python Lex & Yacc
License:        BSD-3-Clause
Group:          Development/Languages/Python
Source:         http://www.dabeaz.com/%{modname}/%{modname}-%{version}.tar.gz
Patch0:         python-ply-shebangs.patch
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  python-devel
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%py_requires
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%endif
%if 0%{?suse_version} > 1110 || 0%{?fedora} > 12 || 0%{?mdkversion}
BuildArch:      noarch
%endif

%description
PLY is yet another implementation of lex and yacc for Python. Some notable
features include the fact that its implemented entirely in Python and it
uses LALR(1) parsing which is efficient and well suited for larger grammars.

PLY provides most of the standard lex/yacc features including support for empty 
productions, precedence rules, error recovery, and support for ambiguous grammars. 

PLY is extremely easy to use and provides very extensive error checking. 
It is compatible with both Python 2 and Python 3.

%package doc
Summary:        Python Lex & Yacc
License:        LGPL-2.1+
Group:          Development/Languages/Python
Requires:       %{name} = %{version}

%description doc
PLY is yet another implementation of lex and yacc for Python. Some notable
features include the fact that its implemented entirely in Python and it
uses LALR(1) parsing which is efficient and well suited for larger grammars.

PLY provides most of the standard lex/yacc features including support for empty 
productions, precedence rules, error recovery, and support for ambiguous grammars. 

PLY is extremely easy to use and provides very extensive error checking. 
It is compatible with both Python 2 and Python 3.

%prep
%setup -q -n %{modname}-%{version}
%patch0 -p1

%build
export CFLAGS="%{optflags}"
python setup.py build

%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
chmod a-x test/*

%clean
rm -rf %{buildroot}

%files
%defattr(-,root,root,-)
%doc ANNOUNCE CHANGES README TODO
%python_sitelib/%{modname}*

%files doc
%defattr(-,root,root,-)
%doc doc example test

%changelog
openSUSE Build Service is sponsored by