File python-pydot.spec of Package python-pydot

#
# spec file for package python-pydot
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
#
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

%define modname pydot
Name:           python-%{modname}
Version:        1.0.28
Release:        0
Url:            http://code.google.com/p/pydot
Summary:        Create (dot) graphs from python
License:        MIT
Group:          Development/Libraries/Python
Source:         http://%{modname}.googlecode.com/files/%{modname}-%{version}.tar.gz
Source1:        example-demo.py
Source2:        example-rank.py
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  python-devel
Requires:       python-pyparsing
Requires:       graphviz
%if 0%{?suse_version} <= 1110
%{!?python_sitelib:  %global python_sitelib  %(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
%else
BuildArch:      noarch
%py_requires
%endif

%description
pydot allows to easily create both directed and non directed graphs from Python. 
Currently all attributes implemented in the Dot language are supported (up to Graphviz 2.16).

%prep
%setup -q -n %{modname}-%{version}
mkdir examples && cp %{SOURCE1} %{SOURCE2} examples

%build
export CFLAGS="%{optflags}"
python setup.py build

%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
rm -rf %{buildroot}/usr/{LICENSE,README} # Wronly installed by setup script

%clean  
rm -rf %{buildroot}

%files
%defattr(-,root,root,-)
%doc README LICENSE examples
%{python_sitelib}/dot_parser.py*
%{python_sitelib}/%{modname}.py*
%{python_sitelib}/%{modname}-%{version}-py%{py_ver}.egg-info

%changelog
openSUSE Build Service is sponsored by